A+B series of questions six

Topic description

Your task is to calculate the sum of some integers.

enter

Input contains multiple test cases, and one case one line.
 Each case starts with an integer N, and then N integers follow in the same line. 

output

For each test case you should output the sum of N integers in one line, and with one line of output for each line in input. 

sample input

4 1 2 3 4
5 1 2 3 4 5

Sample output

10
15

Time Limit: 1 Sec Memory Limit: 128 MB

Code:

#include<stdio.h>  
int main()
{  
    int n = 0;
    int sum = 0;
    int temp = 0;  
    while(scanf("%d", &n) != EOF)
    {  
        sum = 0;  
        while(n--)
        {  
            scanf("%d", &temp);  
            sum += temp;  
        }  
        printf("%d\n", sum);  
    }  
    return 0;  
}

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=325646353&siteId=291194637