Tree Traversals Again (tree traversal) (stack)

03-Tree 3 Tree Traversals Again (25 points)

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

 
    

3 4 2 6 5 1

Question meaning: input a tree through stack and in-order traversal, and then need to output its post-order traversal

AC code:

#include <cstdio>   
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <cstring>
#include <vector>
#include <list>
#include <map>
#include <stack>
#include <queue>
using namespace std;
#define ll long long
typedef struct Tree
{
	int data;
	Tree *l,*r;	 	
}*BiTree;
stack<int> q;
int sum
int n;
void Creat(BiTree &T)
{
	if(sum == 2*n)
		return;
	char x[11];
	cin >> x;
	sum++;
	if(x[1] == 'u')
	{
		int x;
		cin >> x;
		q.push(x);
		T = new Tree;
		T->l = T->r = NULL;
		Creat(T->l);
		T->data = q.top();
		q.pop();
		Creat(T->r);
	}
	return;
}
void endorder(BiTree T)
{
	if(!T)
		return;
	endorder(T->l);
	endorder(T->r);
	if(sum == 2*n)
		cout << T->data;
	else
		cout <<' '<< T->data;
	sum++;
}
intmain()
{
	BiTree T;
	cin >> n;
	sum = 0;
	Creat(T);
	end order(T);
	cout << endl;
    //cout << "AC" <<endl;
    return 0;
}
Reflection: At the beginning, the stack was written as a queue...

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=325581411&siteId=291194637