NYOJ 18 The Triangle form filling method, ordinary dp

Topic link:

http://acm.nyist.edu.cn/JudgeOnline/problem.php?pid=18

The Triangle

Time Limit: 1000 ms | Memory Limit: 65535 KB
Difficulty: 4
 
describe

7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

 
enter
Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.
output
Your program is to write to standard output. The highest sum is written as an integer.
sample input
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
Sample output
30 



Analysis:
dp[i][j]=f_max(dp[i+1][j],dp[i+1][j+1])+a[i][j]; the

code is as follows:

 
#include<bits/stdc++.h>
#define pai 3.1415926535898
using namespace std;
int f_max(int a,int b)
{
    if(a>b)
    {
        return a;
    }else
    {
        return b;
    }
}
intmain ()
{
    int n;
    scanf("%d",&n);
    int a[n][n];
    memset(a,0,sizeof(a));
    for(int i=0;i<n;i++)
    {
        for(int j=0;j<=i;j++)
        {
            scanf("%d",&a[i][j]);
        }
    }
    int dp[n][n];
    memset(dp,0,sizeof(dp));
    for(int j=0;j<n;j++)
    {
        dp[n-1][j]=a[n-1][j];
    }
    for(int i=n-2;i>=0;i--)
    {
        for(int j=0;j<=i;j++)
        {
            dp[i][j]=f_max(dp[i+1][j],dp[i+1][j+1])+a[i][j];
        }
    }
    printf("%d\n",dp[0][0]);
    return 0;
}
        

 



Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=325383289&siteId=291194637