female 1852 Ants

Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time.

Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output

4 8
38 207

Source

 
The shortest time must be when all the ants move closer. At this time, there is no interleaving. Then, for the longest time, we can think that each ant is independent. It is conceivable that any two ants move farther away from each other. One end to act, assuming that they are a, b, respectively, the nearest end, the total length is l, if not staggered, there are two cases, l - a, l - b, if staggered, there will be l - (a + b) / 2 is definitely not the longest time. Obviously, the maximum value is in the first two cases, so only the maximum distance of each ant from the far end is required. After a collision, the road to be traveled may be reduced.
Code:
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <map>
using namespace std;
int t;
int m,n,s[1000000];
int min_,max_;
int main()
{
    int d;
    scanf("%d",&t);
    while(t --)
    {
        scanf("%d%d",&m,&n);
        max_ = min_ = 0;
        while(n --)
        {
            scanf("%d",&d);
            min_ = max(min_,min(d,m - d));
            max_ = max(max_,max(d,m - d));
        }
        printf("%d %d\n",min_,max_);
    }
}

 

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=325303283&siteId=291194637