HDOJ-1852 More is better

More is better

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)
Total Submission(s): 24375    Accepted Submission(s): 8751


Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
 

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
 

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.
 

Sample Input
  
   
   
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8
 

Sample Output
  
   
   
4 2
Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.
 介个题就是用并查集就行了,但是要另外开一个存跟节点所存的数据的数量,找出最多的就行啦...(数组大小一定要够,眼瞎了才开了1000)
代码:
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#define M 10000000+10
using namespace std;
int fa[M],t[M];
void init()
{
	for(int i=1;i<M;i++){
		fa[i]=i;
		t[i]=1;
	}
}
int findroot(int x)
{
	if(x!=fa[x]) fa[x]=findroot(fa[x]);
	return fa[x];
}
void Union(int x,int y)
{
	int nx=findroot(x);
	int ny=findroot(y);
	if(nx>ny){
		fa[nx]=ny;
		t[ny]=t[nx]+t[ny];
	}
	if(nx<ny){
		fa[ny]=nx;
		t[nx]=t[ny]+t[nx];
	}
}
int main()
{
	int n;
	while(~scanf("%d",&n))
	{
		init();
		if(n==0){
			printf("1\n");
			continue;
		}
		for(int i=1;i<=n;i++)
		{
			int a,b;
			scanf("%d%d",&a,&b);
		    Union(a,b);
		}
		int maxi=1;
		for(int i=1;i<=n;i++){
			maxi=max(maxi,t[i]);
		}
		printf("%d\n",maxi);
	}
	return 0;
}


Guess you like

Origin blog.csdn.net/Poseidon__ming/article/details/52088660