D:Sequence Swapping

BaoBao has just found a strange sequence {<, >, <, >, , <, >} of length in his pocket. As you can see, each element <, > in the sequence is an ordered pair, where the first element in the pair is the left parenthesis '(' or the right parenthesis ')', and the second element in the pair is an integer.

As BaoBao is bored, he decides to play with the sequence. At the beginning, BaoBao's score is set to 0. Each time BaoBao can select an integer , swap the -th element and the -th element in the sequence, and increase his score by , if and only if , '(' and ')'.

BaoBao is allowed to perform the swapping any number of times (including zero times). What's the maximum possible score BaoBao can get?

Input

There are multiple test cases. The first line of the input contains an integer , indicating the number of test cases. For each test case:

The first line contains an integer (), indicating the length of the sequence.

The second line contains a string () consisting of '(' and ')'. The -th character in the string indicates , of which the meaning is described above.

The third line contains integers (). Their meanings are described above.

It's guaranteed that the sum of of all test cases will not exceed .

Output

For each test case output one line containing one integer, indicating the maximum possible score BaoBao can get.

Sample Input

4
6
)())()
1 3 5 -1 3 2
6
)())()
1 3 5 -100 3 2
3
())
1 -1 -1
3
())
-1 -1 -1

Sample Output

24
21
0
2

Hint

For the first sample test case, the optimal strategy is to select in order.

For the second sample test case, the optimal strategy is to select in order.

It is a dp, dp[i][j] represents the maximum value when the ith left parenthesis is expanded to the jth.

Then update it.

But what he hasn't arrived can't be treated the same as what he's already been.

Mad mentally retarded,

 

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=1e3+88;
char s[N];
int n,p[N],nxt[N];
long long sum[N],v[N];
long long mx[2][N];
int main(){
    int T;
    while(scanf("%d",&T)!=EOF){
    while(T--){
        scanf("%d",&n);
        long long ans=0;
        int tot=0,f=0;
        scanf("%s",s+1);
        for(int i=1;i<=n;++i) scanf("%lld",v+i);
        for(int i=n;i>=1;--i) if(s[i]=='(') p[++tot]=i;
        for(int i=1;i<=n;++i) sum[i]=sum[i-1]+(s[i]==')'?v[i]:0);
        memset(nxt,0,sizeof(nxt)); 
        for(int i=1;i<=n;++i) if(s[i]==')') {
            if(f) nxt[f]=i;
            f=i;
        }
        for(int i=1;i<=n;++i) mx[1][i]=mx[0][i]=0;
        mx[1][0]=mx[0][0]=-(1LL<<60);
        int cur=0;
        for(int i=1;i<=tot;++i) {
            for(int j=p[i]+1;j<=n;++j) if(s[j]==')') mx[cur][j]=v[p[i]]*(sum[j]-sum[p[i]])+mx[cur^1][j];
            for(int j=n;j>=p[i];--j) if(s[j]==')') mx[cur][j]=max(mx[cur][nxt[j]],mx[cur][j]);
            for(int j=p[i]-1;j>=1;--j) if(s[j]==')') mx[cur][j]=max(mx[cur^1][j],mx[cur][nxt[j]]);
            for(int j=1;j<=n;++j) if(s[j]==')') ans=max(ans,mx[cur][j]);
            cur^=1;
        }
        printf("%lld\n",ans);
    }
    }
}

 

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=325067266&siteId=291194637