Card Game (Second Edition)+expectation

Fat brother and Maze are playing a kind of special (hentai) game with some cards. In this game, every player gets N cards at first and these are their own card deck. The game goes for N rounds and in each round, Fat Brother and Maze would draw one card from their own remaining card deck randomly and compare for the integer which is written on the cards. The player with the higher number wins this round and score 1 victory point. And then these two cards are removed from the game such that they would not appear in the later rounds. As we all know, Fat Brother is very clever, so he would like to know the expect number of the victory points he could get if he knows all the integers written in these cards.

Note that the integers written on these N*2 cards are pair wise distinct. At the beginning of this game, each player has 0 victory point.


Input

The first line of the data is an integer T (1 <= T <= 100), which is the number of the text cases.

Then T cases follow, each case contains an integer N (1 <=N<=10000) which described before. Then follow two lines with N integers each. The first N integers indicate Fat Brother’s cards and the second N integers indicate Maze’s cards.

All the integers are positive and no more than 10000000.

Output

For each case, output the case number first, and then output the expect number of victory points Fat Brother would gets in this game. The answer should be rounded to 2 digits after the decimal point.

Sample Input
2
1
1
2
2
1 3
2 4
Sample Output
Case 1: 0.00
Case 2: 0.50
 
  
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;

const int N=1e5+10;
int a[N],b[N];

inline char getschar(){
    char ch=getchar();
    while(ch==' '||ch=='\n')ch=getchar();
    return ch;
}

int main(){
    int t;
    freopen("in.txt","r",stdin);
    scanf("%d",&t);
    int z = 1;
    while(t--){
        int n;
        scanf("%d",&n);
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        for(int i=0;i<n;i++)
            scanf("%d",&b[i]);
        sort(b,b+n);
        double years=0;
        for(int i=0;i<n;i++){
            int t=lower_bound(b,b+n,a[i])-b;
            //cout<<t<<endl;
            ans+=t;
        }
        printf("Case %d: %.2lf\n",z++,ans/(n*1.0));
    }
}

 

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=324718764&siteId=291194637