POJ #3041 Asteroids 3041 Hungarian Algorithm for Minimum Coverage Maximum Matching for Bipartite Graphs

Description


 

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 
Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS: 
The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
X.X 
.X. 
.X.
 

OUTPUT DETAILS: 
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

 

ideas


 

  The modeling of this problem is very classic. We regard each row as an X node, each column as a Y node, and each target corresponds to an edge. Destroying all targets with the least number of launches means selecting The minimum number of points such that at least one endpoint of any edge is selected. And this corresponds to the definition of the concept of minimum coverage of a bipartite graph. From the theorem, it is known that the minimum number of points covered by a bipartite graph = the maximum number of matches, so the Hungarian algorithm is used to solve this problem.

  The AC codes are as follows:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>

const int maxn = 510;
const int maxk = 10010;
int n,k;
int line[maxn][maxn];
bool used[maxn];
int next[maxn];

bool find (int x) {
    for (int i = 1; i <= n; i++) {
        if (line[x][i] &&!used[i]) {
            used[i] = true;
            if (!next[i] || find(next[i])) {
                next[i] = x;
                return true;
            }
        }
    }
    return false;
}

int match() {
    int sum = 0;
    for (int i = 1; i <= n; i++) {
        memset(used, 0, sizeof(used));
        if (find(i)) sum++;
    }
    return sum;
}

int main(void) {
    int u,v;
    while(~scanf("%d%d", &n, &k)) {
        memset(line, 0, sizeof(line));
        memset(next, 0, sizeof(next));
        while(k--) {
            scanf("%d%d", &u, &v);
            line[u][v] = 1 ;
        }
        printf("%d\n", match());
    }
    return 0;
}
View Code

 

  

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=324412637&siteId=291194637