Supermarket | Greedy + Union Check

Supermarket | Greedy + Union Check


from poj 1456
from acwing 145
Time limit: 2s
Memory limit: 65M

Description:

A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σx∈Sellpx. An optimal selling schedule is a schedule with a maximum profit.
For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80.
img
Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products.

Input

A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.

Output

For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.

Sample Input

4  50 2  10 1   20 2   30 1

7  20 1   2 1   10 3  100 2   8 2
   5 20  50 10

Sample Output

80
185

Hint

The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.


Main idea:

A supermarket has some products that are about to expire, and can only sell one product per day. Given the profit and expiration date of these expired products, ask you what is the maximum revenue that this supermarket can get.

When you look at this topic, you must think of greed the first time! ?

Compared with pure greed, the use of merge search can make some optimizations, that is, point every day to a certain day before this day (including this day) that you can sell goods, such as goods on the 4th, 5th, and 6th days. If there is a product that expires on the sixth day at this time, it is pure greedy, and it needs to traverse 5, 4 until 3, and the concatenation is to directly point 6 to 3.

AC code:

#include<iostream>
#include<algorithm>
using namespace std;
#define pii pair<int,int>
pii w[10005];               //存储商品信息
int father[10005];          //并查集用来存该商品最晚能卖的那天
int find(int x){
    
    
    if(father[x] == x)      //直到找到了当天还没有商品需要卖出的那天
        return x;
    return father[x] = find(father[x]);
}
bool cmp(pii a,pii b){
    
    
    return a.first > b.first;   //贪心,按照利润从大到小排序
}
int n,max_day,sum;            //商品数,最大过期日期,最大利益
int main(){
    
    
    while(cin>>n){
    
    
        max_day = sum = 0;
        for(int i = 1;i <= n;++i)
            cin>>w[i].first>>w[i].second,max_day = max(max_day,w[i].second);
        sort(w + 1,w + 1 + n,cmp);
        for(int i = 1;i <= max_day;++i)
            father[i] = i;
        for(int i = 1;i <= n;++i){
    
    
            int d = find(w[i].second);
            if(d){
    
    
                father[d] = d - 1;            //该天卖了过后就不能再卖了,于是指向前一天
                sum += w[i].first;
            }
        }
        cout<<sum<<"\n";
    }
    return 0;
}

Other methods:
pure greedy
greedy + priority queue

Guess you like

Origin blog.csdn.net/qq_45985728/article/details/113578083