1018 Public Bike Management (30 point(s))

1018 Public Bike Management (30 point(s))

There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city.

The Public Bike Management Center (PBMC) keeps monitoring the real-time capacity of all the stations. A station is said to be in perfect condition if it is exactly half-full. If a station is full or empty, PBMC will collect or send bikes to adjust the condition of that station to perfect. And more, all the stations on the way will be adjusted as well.

When a problem station is reported, PBMC will always choose the shortest path to reach that station. If there are more than one shortest path, the one that requires the least number of bikes sent from PBMC will be chosen.

The above figure illustrates an example. The stations are represented by vertices and the roads correspond to the edges. The number on an edge is the time taken to reach one end station from another. The number written inside a vertex S is the current number of bikes stored at S. Given that the maximum capacity of each station is 10. To solve the problem at S​3​​, we have 2 different shortest paths:

  1. PBMC -> S​1​​ -> S​3​​. In this case, 4 bikes must be sent from PBMC, because we can collect 1 bike from S​1​​ and then take 5 bikes to S​3​​, so that both stations will be in perfect conditions.

  2. PBMC -> S​2​​ -> S​3​​. This path requires the same time as path 1, but only 3 bikes sent from PBMC and hence is the one that will be chosen.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 numbers: C​max​​ (≤100), always an even number, is the maximum capacity of each station; N (≤500), the total number of stations; S​p​​, the index of the problem station (the stations are numbered from 1 to N, and PBMC is represented by the vertex 0); and M, the number of roads. The second line contains N non-negative numbers C​i​​ (i=1,⋯,N) where each C​i​​ is the current number of bikes at S​i​​ respectively. Then M lines follow, each contains 3 numbers: S​i​​, S​j​​, and T​ij​​ which describe the time T​ij​​ taken to move betwen stations S​i​​ and S​j​​. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in one line. First output the number of bikes that PBMC must send. Then after one space, output the path in the format: 0−>S​1​​−>⋯−>S​p​​. Finally after another space, output the number of bikes that we must take back to PBMC after the condition of S​p​​ is adjusted to perfect.

Note that if such a path is not unique, output the one that requires minimum number of bikes that we must take back to PBMC. The judge's data guarantee that such a path is unique.

Sample Input:

10 3 3 5
6 7 0
0 1 1
0 2 1
0 3 3
1 3 1
2 3 1

Sample Output:

3 0->2->3 0

Example: 

#include<iostream>
#include<vector>
#include<list>

using namespace std;

typedef int Vertex;
struct AdjNode {
    Vertex Adj;
    int    Dist;
};
struct Graph {
    int Nv;
    int Ne;
    vector<list<AdjNode>> G;
};

vector<Vertex> Path, Temp;
int minDist, Dist, minIn, minOut, In, Out;

void DFS(Graph &G, Vertex s, Vertex t, vector<int> &Bikes, vector<bool> &Visited)
{
    Temp.push_back(s), Visited[s] = true;
    int diff = Bikes[s] - Bikes[0], InTmp = In, OutTmp = Out;
    if(diff > 0) {
        In += diff;
    } else if(diff < 0) {
        if(In + diff >= 0) In += diff;
        else Out -= In + diff, In = 0;
    }
    if(s == t) {
        bool update = false;
        if(minDist == -1) {
            minDist = Dist, update = true;
        } else if(Dist < minDist) {
            minDist = Dist, update = true;
        } else if(Dist == minDist) {
            if(Out < minOut) update = true;
            else if(Out == minOut && In < minIn) update = true;
        }
        if(update) Path = Temp, minIn = In, minOut = Out;
    } else {
        for(auto &x : G.G[s]) {
            if(!Visited[x.Adj]) {
                Dist += x.Dist;
                DFS(G, x.Adj, t, Bikes, Visited);
                Dist -= x.Dist;
            }
        }
    }
    In = InTmp, Out = OutTmp;
    Temp.pop_back(), Visited[s] = false;
}

int main()
{
    int C, N, P, M;
    cin >> C>> N >> P >> M;
    vector<int> Bikes(N+1);
    Graph G;
    G.Nv = N, G.Ne = M, G.G.resize(N+1);
    Bikes[0] = C/2;
    for(int i = 1; i <= N; i++) cin >> Bikes[i];
    for(int i = 1; i <= M; i++) {
        int Si, Sj, Tij;
        cin >> Si >> Sj >> Tij;
        G.G[Si].push_back({Sj, Tij});
        G.G[Sj].push_back({Si, Tij});
    }
    vector<bool> Visited(N+1);
    Path.reserve(N+1);
    Temp.reserve(N+1);
    minDist = -1, Dist = 0;
    minIn = In = minOut = Out = 0;
    DFS(G, 0, P, Bikes, Visited);
    cout << minOut;
    for(auto x = Path.begin(); x != Path.end(); x++)
        cout << (x == Path.begin() ? " " : "->") << *x;
    cout << ' ' << minIn << endl;
}

Ideas:

Use DFS depth-first search.

Note that the path cannot be reversed, and at the same time adjust the number of bicycles at all stops on the path to N/2,

For the current site> N/2, take away the excess part and put it in In, and recycle it to the management center in the future;

For the current site <N/2, it will be taken out from In, if it is not enough, it will be dispatched from the management center immediately, that is, Out

Finally, according to the priority given by the title, that is, Dist> cars dispatched by the management center> cars recycled by the management center, select the appropriate path

Guess you like

Origin blog.csdn.net/u012571715/article/details/114002024