PAT A1026 Table Tennis (30point(s))

A table tennis club has N tables available to the public. The tables are numbered from 1 to N. For any pair of players, if there are some tables open when they arrive, they will be assigned to the available table with the smallest number. If all the tables are occupied, they will have to wait in a queue. It is assumed that every pair of players can play for at most 2 hours.

Your job is to count for everyone in queue their waiting time, and for each table the number of players it has served for the day.

One thing that makes this procedure a bit complicated is that the club reserves some tables for their VIP members. When a VIP table is open, the first VIP pair in the queue will have the priviledge to take it. However, if there is no VIP in the queue, the next pair of players can take it. On the other hand, if when it is the turn of a VIP pair, yet no VIP table is available, they can be assigned as any ordinary players.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (≤10000) - the total number of pairs of players. Then N lines follow, each contains 2 times and a VIP tag: HH:MM:SS - the arriving time, P - the playing time in minutes of a pair of players, and tag - which is 1 if they hold a VIP card, or 0 if not. It is guaranteed that the arriving time is between 08:00:00 and 21:00:00 while the club is open. It is assumed that no two customers arrives at the same time. Following the players’ info, there are 2 positive integers: K (≤100) - the number of tables, and M (< K) - the number of VIP tables. The last line contains M table numbers.

Output Specification:

For each test case, first print the arriving time, serving time and the waiting time for each pair of players in the format shown by the sample. Then print in a line the number of players served by each table. Notice that the output must be listed in chronological order of the serving time. The waiting time must be rounded up to an integer minute(s). If one cannot get a table before the closing time, their information must NOT be printed.

Sample Input:

9
20:52:00 10 0
08:00:00 20 0
08:02:00 30 0
20:51:00 10 0
08:10:00 5 0
08:12:00 10 1
20:50:00 10 0
08:01:30 15 1
20:53:00 10 1
3 1
2

Sample Output:

08:00:00 08:00:00 0
08:01:30 08:01:30 0
08:02:00 08:02:00 0
08:12:00 08:16:30 5
08:10:00 08:20:00 10
20:50:00 20:50:00 0
20:51:00 20:51:00 0
20:52:00 20:52:00 0
3 3 2
  • Ideas:
    ignorant, it can not be written

  • Sample analysis:
    Here Insert Picture Description

  • code: Unfinished necessarily Continued ...

#include <bits/stdc++.h>
using namespace std;
const int maxn = 110;
struct Player{
	int id, arrive_time, play_time, tag;
	Player(int _id, int _arr, int _ply, int _t) : id(_id), arrive_time(_arr), play_time(_ply), tag(_t){}
	bool operator < (const Player & b) const {
		return arrive_time > b.arrive_time;
	}
};
priority_queue<Player> players, vip_players;

struct Table{
	int id, end_time, tag, cnt;
	Table(int _id, int _e, int _t, int _c) : id(_id), end_time(_e), tag(_t), cnt(_c){}
	bool operator < (const Table & tmp) const{
		return end_time > tmp.end_time;
	}
};
priority_queue<Table> pq; 
int GetTime(int h, int m, int s){
	return h * 3600 + m * 60 + s;
}
void PrintTime(int time){
	printf("%02d:%02d:%02d ", time / 3600, time / 60 % 60, time % 60);
}
bool cmp(Player a, Player b){
	return a.arrive_time < b.arrive_time;
} 
bool cmp2(Table a, Table b){
	return a.id < b.id;
}
int main(){
	int n, n_table, n_vip;
	scanf("%d", &n);
	int open_time = GetTime(8, 0, 0), close_time = GetTime(21, 0, 0);
	for(int i = 0; i < n; ++i){
		int th, tm, ts, tp, ttag, tarr;
		scanf("%d:%d:%d %d %d", &th, &tm, &ts, &tp, &ttag);
		tarr = GetTime(th, tm, ts);
		if(tarr < close_time){
			players.push(Player(i, tarr, tp <= 120 ? tp * 60 : 120 * 60, ttag));
			if(ttag == 1) vip_players.push(Player(i, tarr, tp <= 120 ? tp * 60 : 120 * 60, ttag));
		}
	}
//	sort(players.begin(), players.end(), cmp);
	scanf("%d %d", &n_table, &n_vip);
	unordered_map<int, bool> mp_vip;
	for(int i = 0; i < n_vip; ++i){
		int tvip;
		scanf("%d", &tvip);
		mp_vip[tvip] = true;
	}
	for(int i = 1; i <= n_table; ++i){
		int ttag = 0;
		if(mp_vip[i] == true)  ttag = 1;
		pq.push(Table(i, open_time, ttag, 0));
	}
//	int idex = 0;
	unordered_map<int, bool> vis;
	while(!players.empty()){
		Table now = pq.top();
		Player first = players.top();
		Player vip_first = vip_players.top();
		now.cnt++;
		if(vis[first.id] == false){
			int wait_time = 0, serve_time = now.end_time;
			if(serve_time >= close_time) break; 
			if(now.tag == 1 && now.end_time >= vip_first.arrive_time){
				wait_time = now.end_time - vip_first.arrive_time;
				now.end_time += vip_first.play_time;
				PrintTime(vip_first.arrive_time); 
				vip_players.pop();
				vis[vip_first.id] = true;
			}else{
				if(now.end_time <= first.arrive_time){
					serve_time = first.arrive_time;
					now.end_time = first.arrive_time + first.play_time;
				}else{
					wait_time = now.end_time - first.arrive_time;
					now.end_time += first.play_time;
				}
				if(first.tag == 1)  vip_players.pop();
				PrintTime(first.arrive_time); 
				players.pop(); 
			}
			PrintTime(serve_time); 
			printf("%d\n", (int)round(wait_time / 60.0));
			pq.pop();
			pq.push(now);		
		}else players.pop(); 
	}
	vector<Table> ans;
	while(!pq.empty()){
		ans.push_back(pq.top());
		pq.pop();
	}
	sort(ans.begin(), ans.end(), cmp2);
	for(int i = 0; i < ans.size(); ++i){
		printf("%d", ans[i].cnt);
		if(i < ans.size() - 1) printf(" ");
	}
	return 0;
}

Here Insert Picture Description

Published 271 original articles · won praise 5 · Views 6468

Guess you like

Origin blog.csdn.net/qq_42347617/article/details/104287654