2030.Reachable Numbers

Title description

Let’s denote a function f(x) in such a way: we add 1 to x, then, while there is at least one trailing zero in the resulting number, we remove that zero. For example,

f(599)=6: 599+1=600→60→6;
f(7)=8: 7+1=8;
f(9)=1: 9+1=10→1;
f(10099)=101: 10099+1=10100→1010→101.
We say that some number y is reachable from x if we can apply function f to x some (possibly zero) times so that we get y as a result. For example, 102 is reachable from 10098 because f(f(f(10098)))=f(f(10099))=f(101)=102; and any number is reachable from itself.

You are given a number n; your task is to count how many different numbers are reachable from n.

enter

The first line contains an integer N (1 ≤ n ≤10 ^ 9) Multi-instance test

Output

Print an integer: the number of different numbers available from it n

Sample input

1098

Sample output

20

Code content

#include <iostream>
using namespace std;

int qwe(int n)//除去末尾0
{
    
    
	while (n!=0)
	{
    
    
		if (n % 10 == 0)
			n = n / 10;
		else
			return n;
	}
}

int main()
{
    
    
	int n,times;
	while (cin >> n)
	{
    
    
		times = 0;
		if (n <= 9)
			cout << "9" << endl;
		else
		{
    
    
			while (n >= 10)
			{
    
    
				n = (qwe(n + 1));
				times++;
			}
			cout << times + 9 << endl;
		}
	}
	return 0;
}

Guess you like

Origin blog.csdn.net/weixin_51800059/article/details/111400453