Hash search + secondary detection method 1078 Hashing (25 points)

1078 Hashing (25分)

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:
Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (≤10
​4
​​ ) and N (≤MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print “-” instead.

Sample Input:

4 4
10 6 4 15

Sample Output:

0 1 4 -

Problem-solving
Given a hash table size M, (converted to a prime number not less than M);
given a number N;
output the subscripts after storing each number in order;

Pay attention to the
secondary detection method, each time you try + t squared, the boundary condition is t <M / 2, if you have not found a location to store at this time, it means that it cannot be stored;

#include<iostream>
#include<cmath>
#include<algorithm>
using namespace std;


bool isPrim(int n)
{
	if(n<2) return false;
	if(n==2) return true;
	for(int i=2;i<=sqrt(n);i++)
		if(n%i==0) return false;
	return true;
}


int nextPrim(int n)
{//素数
//不能被2——根号n的所有数整除的数 
	while(!isPrim(n))
		++n;
		
	return n;	
}

const int maxN=10010;
int M,N;
int Hash[maxN];
void input()
{
	cin>>M>>N;
	M=nextPrim(M);		
	fill(Hash,Hash+M,-1);    //全部置为-1
	
	int tmp;
	for(int i=0;i<N;i++)
	{
		cin>>tmp;
		int t=0;
		int index= tmp%M;
		int flag=0;
		
		while(t<M)
		{
		t++;
		if(Hash[index]==-1){
		Hash[index]=tmp;
		cout<<index;
		flag=1;
		break;
		}
		else
			index=(tmp%M+t*t)%M;		
		}
		if(flag==0)
			cout<<"-";
		if(i!=N-1)
			cout<<" ";
	}
}


int main()
{
	input();
}
Published 105 original articles · won praise 6 · views 4937

Guess you like

Origin blog.csdn.net/BLUEsang/article/details/105632113