Comprehensive Training of "Comprehensive Practice of Enterprise Projects" (3)

Required documents and simulator files

Comprehensive Training Document of "Comprehensive Practice of Enterprise Projects" (3)

Introduction:
The focus of this exercise is on subnetting skills, basic device configuration, and OSPF routing protocol. After configuring all the devices, you need to test the end-to-end connectivity and check your configuration.

learning target:

  • Design an addressing plan and record it.
  • Apply the basic configuration on the device.
  • Configure the router priority and router ID.
  • Configure OSPF routing.
  • Disable routing updates on the appropriate interface.
  • Verify complete connectivity between all devices in the topology.

Experimental Topology
Insert picture description here
Address Table
Insert picture description here
Task 1: Design an addressing scheme and record it.
Use 172.16.0.0/16 to create an effective address scheme that meets the following requirements: (IP address allocation is performed in order of network size from large to small. On the subnet After dividing and assigning to the interface with the required number of hosts, then assign the WAN link from R5 to R2 from the network segment that can be divided into subnets, and then assign the address to the WAN link from R4 to R6.)
Insert picture description here
Note: It is also necessary to assign subnets to the two serial links in the topology, namely R5 to R2 and R4 to R6 (R5 will get the first IP address [DCE] on the link between it and R2. R4 [ DCE] will get the first IP address on the link between it and R6.)

Task 2: Apply basic configuration.
1. Common part:
Use the following table to complete the basic router configuration on each router. At the same time, make sure to configure the IP address and host name.
Insert picture description here
Tip: Enter the privilege mode to encrypt the password, not the plain text.
Second, the configuration requirements of each router:
Branch:
Configure the default route to reach R1.

ISP:
Configure static routes to reach routes other than 192.168.1.0.

R1:
1. Configure a default route to reach the ISP, and the next hop is the IP address.
2. R1 will never participate in DR / BDR elections.
3. Re-publish the S port as a direct connection route to OSPF with subnets.
4. Create a Loopback 0 interface. For the IP address, see the address table. Use this address as the router-id of the router. The network segment belongs to area 0 and is announced to the OSPF process together with other network segments.
5. Republish the default route to the OSPF process.

R2:
1. Create Loopback 0 interface. See the address table for the IP address. Use this address as the router-id of the router. The network segment belongs to area 0, and it is announced to the OSPF process together with other network segments.
2. Configure the interface connected to the switch as a passive interface.
3. R2 will always become DR.
4. Republish the default route learned from R1 to the OSPF process.

R3:
1. Create Loopback 0 interface. See the address table for the IP address. Use this address as the router-id of the router. This network segment belongs to area 0, and it is announced to the OSPF process together with other network segments.
2. Set the priority of the interface participating in area 0 to 100.
3. Configure the interface connected to the switch as a passive interface.

R4:
1. Create Loopback 0 interface. See the address table for the IP address. Use this address as the router-id of the router. This network segment belongs to area 0, and it is announced to the OSPF process together with other network segments.
2. Configure the interface connected to the switch as a passive interface.
3. Re-advertise the default route learned from R1 to the OSPF process.
4. Set the priority of the interface participating in area 0 to 100.

R5:
1. Create Loopback 0 interface. See the address table for the IP address. Use this address as the router-id of the router and announce it to the OSPF process together with other network segments.
2. Configure the interface connected to the switch as a passive interface.

R6:
1. Create Loopback 0 interface. See the address table for the IP address. Use this address as the router-id of the router and announce it to the OSPF process together with other network segments.
2. Configure the interface connected to the switch as a passive interface.
Note: All priorities should be set on the FA0 / 0 interface.

Task 3: Test and debug:
1. Use show ip route to check whether the network segment of the entire network is completed and test the connectivity of the entire network. .
2. Use the Shutdown / No Shutdown command on the interface to force DR / BDR election.
3. Use the debug ip ospf events command to check the running process of the OSPF protocol.
4. Use show ip ospf neighbor to view OSPF related neighbor information.

Follow me, don't get lost in the simulator

The configuration commands are as follows:

First of all, each router must be divided into subnets, and the subnets can be divided to proceed to the next step.

Router Branch

Router(config)#hostname Branch
Branch(config)#int s1/0
Branch(config-if)#ip add 192.168.1.2 255.255.255.0
Branch(config)#line vty 0 4
Branch(config-line)#password cisco
Branch(config-line)#login
Branch(config)#line console 0
Branch(config-line)#password cisco
Branch(config-line)#login
Branch(config)#enable secret cisco
Branch(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.1

Router ISP

Router(config)#hostname ISP
ISP(config)#int s1/0
ISP(config-if)#ip add 200.100.205.1 255.255.255.252
ISP(config-if)#clock rate 56000
ISP(config)#int f0/0
ISP(config-if)#ip add 199.52.1.1 255.255.255.0
ISP(config)# line vty 0 4
ISP(config-line)#password cisco
ISP(config-line)#login
ISP(config)#line console 0
ISP(config-line)#password cisco
ISP(config-line)#login
ISP(config)#enable secret cisco
ISP(config)#ip route 10.10.10.0 255.255.255.248 s1/0
ISP(config)#ip route 172.16.0.0 255.255.0.0 s1/0

Router R1

Router(config)#hostname R1
R1(config)#int s0/0/0
R1(config-if)#ip add 200.100.205.2 255.255.255.252
R1(config)#int s0/0/1
R1(config-if)#ip add 192.168.1.1 255.255.255.0
R1(config-if)#clock rate 56000
R1(config)#int f0/0
R1(config-if)#ip add 10.10.10.1 255.255.255.248
R1(config-if)#ip ospf priority 0     //不参与选举
R1(config)#int loopback 0
R1(config-if)#ip add 1.1.1.1 255.255.255.255
R1(config)#line vty 0 4
R1(config-line)#password cisco
R1(config-line)#login
R1(config)#line console 0
R1(config-line)#password cisco
R1(config-line)#login
R1(config)#enable secret cisco
R1(config)#ip route 0.0.0.0 0.0.0.0 200.100.205.1
R1(config)#route ospf 1
R1(config-router)#network 10.10.10.0 0.0.0.7 area 0
R1(config-router)#redistribute static subnets
R1(config-router)#default-information originate 
R1(config-router)#redistribute connected subnets 
R1(config-router)#network 1.1.1.1 0.0.0.0 area 0

Router R2

Router(config)#hostname R2
R2(config)#int f0/0
R2(config-if)#ip add 10.10.10.2 255.255.255.248
R2(config-if)#ip ospf priority 255
R2(config)#int f0/1
R2(config-if)#ip add 172.16.40.1 255.255.252.0
R2(config)#int loopback 0
R2(config-if)#ip add 2.2.2.2 255.255.255.255
R2(config)#int s0/0/0
R2(config-if)#ip add 172.16.52.130 255.255.255.252
R2(config-if)#clock rate 56000
R2(config)#line vty 0 4
R2(config-line)#password cisco
R2(config-line)#login
R2(config)#line console 0
R2(config-line)#password cisco
R2(config-line)#login
R2(config)#enable secret cisco
R2(config)#route ospf 1
R2(config-router)#passive-interface f0/1
R2(config-router)#network 172.16.52.128 0.0.0.3 area 1
R2(config-router)#default-information originate
R2(config-router)#network 2.2.2.2 0.0.0.0 area 0
R2(config-router)#network 10.10.10.0 0.0.0.7 area 0
R2(config-router)#network 172.16.0.0 0.0.255.255 area 1

Router R3


Router(config)#hostname R3
R3(config)#int f0/0
R3(config-if)#ip add 10.10.10.3 255.255.255.248
R3(config-if)#ip ospf priority 100
R3(config)#int f0/1
R3(config-if)#ip add 172.16.50.1 255.255.254.0
R3(config)#int loopback 0
R3(config-if)#ip add 3.3.3.3 255.255.255.255
R3(config)#line vty 0 4
R3(config-line)#password cisco
R3(config-line)#login
R3(config)#line console 0
R3(config-line)#password cisco
R3(config-line)#login
R3(config)#enable secret cisco
R3(config)#route ospf 1
R3(config-router)#passive-interface f0/1
R3(config-router)#network 10.10.10.0 0.0.0.7 area 0
R3(config-router)#network 172.16.0.0 0.0.255.255 area 0
R3(config-router)#network 3.3.3.3 0.0.0.0 area 0

Router R4

Router(config)#hostname R4
R4(config)#int s0/0/0
R4(config-if)#ip add 172.16.52.133 255.255.255.252
R4(config-if)#clock rate 56000
R4(config)#int f0/0
R4(config-if)#ip add 10.10.10.4 255.255.255.248
R4(config-if)#ip ospf priority 100
R4(config)#int f0/1
R4(config-if)#ip add 172.16.52.1 255.255.255.128
R4(config)#int loopback 0
R4(config-if)#ip add 4.4.4.4 255.255.255.255
R4(config)#line vty 0 4
R4(config-line)#password cisco
R4(config-line)#login
R4(config)#line console 0
R4(config-line)#password cisco
R4(config-line)#login
R4(config)#enable secret cisco
R4(config)#route ospf 1
R4(config-router)#passive-interface f0/1
R4(config-router)#network 10.10.10.0 0.0.0.7 area 0
R4(config-router)#network 172.16.52.132 0.0.0.3 area 2
R4(config-router)#network 172.16.0.0 0.0.255.255 area 2
R4(config-router)#default-information originate 
R4(config-router)#network 4.4.4.4 0.0.0.0 area 0

Router R5

Router(config)#hostname R5
R5(config)#int f0/0
R5(config-if)#ip add 172.16.44.1 255.255.252.0
R5(config)#int f0/1
R5(config-if)#ip add 172.16.50.1 255.255.254.0
R5(config)#int f0/1
R5(config-if)#ip add 172.16.0.1 255.255.224.0
R5(config)#int s0/0/0
R5(config-if)#ip add 172.16.52.129 255.255.255.252
R5(config)#int loopback 0
R5(config-if)#ip add 5.5.5.5 255.255.255.255
R5(config)#line vty 0 4
R5(config-line)#password cisco
R5(config-line)#login
R5(config)#line console 0
R5(config-line)#password cisco
R5(config-line)#login
R5(config)#enable secret cisco
R5(config)#route ospf 1
R5(config-router)#passive-interface f0/0
R5(config-router)#passive-interface f0/1
R5(config-router)#network 172.16.0.0 0.0.255.255 area 1
R5(config-router)#network 172.16.52.128 0.0.0.3 area 1
R5(config-router)#network 5.5.5.5 0.0.0.0 area 1

Router R6

Router(config)#hostname R6
R6(config)#int s0/0/0
R6(config-if)#ip add 172.16.52.134 255.255.255.252
R6(config)#int f0/0	
R6(config-if)#ip add 172.16.48.1 255.255.254.0
R6(config)#int f0/1
R6(config-if)#ip add 172.16.32.1 255.255.248.0
R6(config)#int loopback 0
R6(config-if)#ip add 6.6.6.6 255.255.255.255
R6(config)#line vty 0 4
R6(config-line)#password cisco
R6(config-line)#login
R6(config)#line console 0
R6(config-line)#password cisco
R6(config-line)#login
R6(config)#enable secret cisco
R6(config)#route ospf 1
R6(config-router)#passive-interface f0/0
R6(config-router)#passive-interface f0/1
R6(config-router)#network 172.16.52.132 0.0.0.3 area 2
R6(config-router)#network 172.16.0.0 0.0.255.255 area 2
R6(config-router)#network 6.6.6.6 0.0.0.0 area 2
Published 13 original articles · Like 43 · Visits 1189

Guess you like

Origin blog.csdn.net/Long_UP/article/details/105116620