POJ [2253] Arbitrage [SPFA judges the positive ring]

Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.

Input 

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output 

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

Sample Input 

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output 

Case 1: Yes
Case 2: No

The main idea:

Given some currencies, and the exchange rates between these currencies, it is required to see if they can make more money than the original through currency exchange.

analysis:

A currency can be seen as a point on the graph, and a conversion method is an edge between the two currencies on the graph.

Note that the edges here are directed edges.

Considering the weights of edges, the weights of A to B are  V_A*R_A_B.

It is required to increase the final amount, that is, to find a positive ring in the picture. In this way, arbitrage can always be achieved in the positive ring.

SPFA is used here to judge the positive ring.

See the code for specific explanation.

 

//#include <bits/stdc++.h>
#include <iostream>
#include <string>
#include <cstring>
#include <queue>
#include <map>
#include <cmath>
#include <vector>
#include <iomanip>

using namespace std;

const int maxn=1005;
const int INF=0x3f3f3f3f;

string names[35];
map<string,int> mp;

double dis[maxn];
int head[maxn];
int vis[maxn],times[maxn];

int ans;
int m,n,s;
double initv;

struct node{
    int u,v;
    double r;
    int next;
}edge[maxn];

void add(int u,int v,double r){
    edge[ans].u=u;
    edge[ans].v=v;
    edge[ans].r=r;
    edge[ans].next=head[u];
    head[u]=ans++;
}

bool spfa(int st){
    memset(vis, 0, sizeof(vis));
    memset(times, 0, sizeof(times));	//times数组记录顶点入队的次数 
    for(int i = 1; i<=n; i++)
        dis[i] = 0;				//初始化其他点的dis值为0

    queue<int> Q;
    Q.push(st);
    vis[st] = 1;
    dis[st] = 1;	//初始货币值为 1 
    while(!Q.empty()){
        int u = Q.front();
        Q.pop(); 
		vis[u] = 0;
        for(int i = head[u]; i!=-1; i = edge[i].next){	 
            int v = edge[i].v;
            if(dis[v] < dis[u]*edge[i].r){	//注意这里的松弛条件
                dis[v] = dis[u]*edge[i].r;
                if(!vis[v]){
                    Q.push(v);
                    vis[v] = 1;
                    if(++times[v]>n) return true;	//某一顶点入队超过 n次,则存在正环 
                }
            }
        }
    }
    return false;
}

int main(){
	int cas=0;
	while(cin>>n&&n){
		mp.clear();
		ans=0;
		++cas;
		memset(head,-1,sizeof(head));
		string tmp;
		int cnt=0;
		for(int i=1;i<=n;i++){
			cin>>tmp;
			names[++cnt]=tmp;
			mp[tmp]=cnt;	//这里将货币名称映射为整型数值 
		}
		cin>>m;
		string tmp1,tmp2;
		double rate;
		int index1,index2;
		for(int i=1;i<=m;i++){
			cin>>tmp1>>rate>>tmp2;
			index1=mp[tmp1];
			index2=mp[tmp2];
			add(index1,index2,rate);	//加入有向边 
		}
		if(spfa(1))  cout<<"Case "<<cas<<": "<<"Yes"<<endl;
		else  cout<<"Case "<<cas<<": "<<"No"<<endl;
	}
	return 0;
}

 

Published 30 original articles · won 5 · 900 views

Guess you like

Origin blog.csdn.net/qq_42840665/article/details/101941241