POJ 2253-Frogger (Floyd modification)

Frogger

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 78072 Accepted: 23723

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists’ sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona’s stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog’s jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy’s stone, Fiona’s stone and all other stones in the lake. Your job is to compute the frog distance between Freddy’s and Fiona’s stone.
Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy’s stone, stone #2 is Fiona’s stone, the other n-2 stones are unoccupied. There’s a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying “Scenario #x” and a line saying “Frog Distance = y” where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

Topic Link

Title effect: a second request to the first stone stone better way most of the most distant minimum. Such as from 1 to 4, the distance is a distance 3,4 to 6, the second way is from 1 to 5 4, 5 and 6 are a distance, it is clear that we should choose the distance piece 3, and an output 3.

Problem-solving ideas: At first I did not understand what it meant, but would like to see Floyd's future is deformed, a little change on the basis of the relaxation operation, seeking maximum of two distances, and then find the smallest two maxima value. AC Code:

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cmath>
using namespace std;
const int N=210;
double map[N][N];
struct node {int x,y;}edge[N];//定义结构体来存放每个石头的坐标用于计算
int n,k=1;
int main()
{
	void floyd();
	while (cin>>n&&n)
	{
		for(int i = 1;i<=n;i++)
		  cin>>edge[i].x>>edge[i].y;
		memset(map,127,sizeof map);//double  127无限大
		for(int i=1;i<=n;i++)
		  for(int j=1;j<=i;j++)
		    if(i==j)
			  map[i][j]=0;
			else
			  map[i][j]=map[j][i]=sqrt((double)(edge[i].x-edge[j].x)*(edge[i].x-edge[j].x)+(double)(edge[i].y-edge[j].y)*(edge[i].y-edge[j].y));//求石头间的距离
		floyd();
		printf("Scenario #%d\n",k++);
		printf("Frog Distance = %.3lf\n",map[1][2]);
		cout<<endl;
	}
	system("pause");
	return 0;
}
void floyd()
{
	for(int j=1;j<=n;j++)
	  for(int i=1;i<=n;i++)
	    for(int k=1;k<=n;k++)
		  map[i][k]=min(map[i][k],max(map[i][j],map[j][k]));//先找最大再找最小
}
Published 33 original articles · won praise 0 · Views 768

Guess you like

Origin blog.csdn.net/aezakmias/article/details/104728114