Triangle LOVE(HDU 4324)

Topic Link

Title Description

Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world!
Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.
Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.

Input Format

The first line contains a single integer t (1 <= t <= 15), the number of test cases.
For each case, the first line contains one integer N (0 < N <= 2000).
In the next N lines contain the adjacency matrix A of the relationship (without spaces). Ai,j = 1 means i-th people loves j-th people, otherwise Ai,j = 0.
It is guaranteed that the given relationship is a tournament, that is, Ai,i= 0, Ai,j ≠ Aj,i(1<=i, j<=n,i≠j).

Output Format

For each case, output the case number as shown and then print “Yes”, if there is a “Triangle Love” among these N people, otherwise print “No”.
Take the sample output for more details.

SAMPLE INPUT

2
5
00100
10000
01001
11101
11000
5
01111
00000
01000
01100
01110

Sample Output

Case #1: Yes
Case #2: No

analysis

Title effect a given n vertices directed graph, it is determined whether the topological sorting.
Straight template to determine if it can not be topologically sorted representatives rings.

Source

#include <bits/stdc++.h>
#define MAXN 2005
using namespace std;
int t,n,cnt=0,in[MAXN];
bool g[MAXN][MAXN];
int read()
{
	int sum;
	char c=getchar();
	while(c<'0'||c>'9')c=getchar();
	sum=c-'0';
	return sum;
}
bool TopSort()
{
	queue<int> q;
	for(int i=1;i<=n;i++)
		if(!in[i])q.push(i);
	int k=0;
	while(!q.empty()){
		int u=q.front();
		q.pop();
		k++;
		for(int i=1;i<=n;i++)
			if(g[u][i]){
				in[i]--;
				if(!in[i])q.push(i);
			}
	}
	if(k!=n)return false;
	return true;
}
int main()
{
	scanf("%d",&t);
	while(t--){
		memset(in,0,sizeof(in));
		scanf("%d",&n);
		for(int i=1;i<=n;i++){
			for(int j=1;j<=n;j++){
				int tmp=read();
				g[i][j]=tmp;
				if(tmp)in[j]++;
			}
		}
		if(TopSort())printf("Case #%d: No\n",++cnt);
		else printf("Case #%d: Yes\n",++cnt);
	}
}
Published 19 original articles · won praise 0 · Views 132

Guess you like

Origin blog.csdn.net/weixin_43960284/article/details/105237223