Legal or Not(HDU 3342)

Topic Link

Title Description

ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many “holy cows” like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost “master”, and Lost will have a nice “prentice”. By and by, there are many pairs of “master and prentice”. But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?
We all know a master can have many prentices and a prentice may have a lot of masters too, it’s legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian’s master and, at the same time, 3xian is HH’s master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not.
Please note that the “master and prentice” relation is transitive. It means that if A is B’s master ans B is C’s master, then A is C’s master.

Input Format

The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y’s master and y is x’s prentice. The input is terminated by N = 0.
TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,…, N-1). We use their numbers instead of their names.

Output Format

For each test case, print in one line the judgement of the messy relationship.
If it is legal, output “YES”, otherwise “NO”.

SAMPLE INPUT

3 2
0 1
1 2
2 2
0 1
1 0
0 0

Sample Output

YES
NO

analysis

Subject to the effect of a given n points, directed graph, determines whether the topological sort m edges.
Straight template to determine if it can not be topologically sorted representatives rings.

Source

#include <bits/stdc++.h>
#define MAXN 105
using namespace std;
struct Edge{
	int v,next;
	Edge(){};
	Edge(int _v,int _next){
		v=_v,next=_next;
	}
}edge[MAXN];
int EdgeCount,head[MAXN];
int n,m,in[MAXN];
void addEdge(int u,int v)
{
	edge[++EdgeCount]=Edge(v,head[u]);
	head[u]=EdgeCount; 
}
bool TopSort()
{
	queue<int> q;
	for(int i=0;i<n;i++)
		if(!in[i])q.push(i);
	int cnt=0;
	while(!q.empty()){
		int u=q.front();
		q.pop();
		cnt++;
		for(int i=head[u];i;i=edge[i].next){
			int v=edge[i].v;
			in[v]--;
			if(!in[v])q.push(v);
		}
	}
	if(cnt!=n)return false;
	return true;
}
int main()
{
	while(scanf("%d%d",&n,&m)!=EOF&&n){
		EdgeCount=0;
		for(int i=0;i<n;i++)head[i]=in[i]=0;	//初始化 
		for(int i=1;i<=m;i++){
			int u,v;
			scanf("%d%d",&u,&v);
			in[v]++;
			addEdge(u,v);
		}
		if(TopSort())printf("YES\n");
		else printf("NO\n");
	}	
} 
Published 19 original articles · won praise 0 · Views 131

Guess you like

Origin blog.csdn.net/weixin_43960284/article/details/105237208