Harmonic Number FJUT 1317 block playing table

In mathematics, the nth harmonic number is the sum of the reciprocals of the first n natural numbers:

In this problem, you are given n, you have to find Hn.

Input
Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 108).

Output
For each case, print the case number and the nth harmonic number. Errors less than 10-8 will be ignored.

SampleInput
12
1
2
3
4
5
6
7
8
9
90000000
99999999
100000000
SampleOutput
Case 1: 1
Case 2: 1.5
Case 3: 1.8333333333
Case 4: 2.0833333333
Case 5: 2.2833333333
Case 6: 2.450
Case 7: 2.5928571429
Case 8: 2.7178571429
Case 9: 2.8289682540
Case 10: 18.8925358988
Case 11: 18.9978964039
Case 12: 18.9978964139

Meaning of the questions: seeking harmonic series
ideas: certainly to be off-line, I began to write out of a pure play table and then RE. . Studies hand block playing table

#include <cstdio>

using namespace std;

const int maxn =1e8+5;
const int N = 2e6+5;///每隔50打一次,缩小内存 
double a[N];

int main()
{
    int t;

    double sum=0;
    int cnt=0;
    a[0]=0;

    for(int i=1;i<=maxn;i++)
    {
        sum+=1.0/i;
        if(i%50==0)///隔50记录一次
            a[++cnt]=sum;
    }

    scanf("%d",&t);

    for(int cas=1;cas<=t;cas++)
    {
        int n;

        scanf("%d",&n);

        double res=a[n/50];///先得到对应块里的值

        for(int i=n/50*50+1;i<=n;i++)///然后暴力出来答案
            res+=1.0/i;

        printf("Case %d: %.11f\n",cas,res);

    }

    return 0;
}
Published 54 original articles · won praise 0 · Views 1217

Guess you like

Origin blog.csdn.net/weixin_44144278/article/details/100161420