Scratch brush HDOJ (2) [HDOJ1001 - Sum Problem]

Scratch brush HDOJ (2) [HDOJ1001 - Sum Problem]

Face questions

Sum Problem

Time Limit: 1000/500 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Problem Description

Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).
In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + … + n.

Input

The input will consist of a series of integers n, one integer per line.

Output

For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.

Sample Input

1
100

Sample Output

1

5050

Author

DOOM III

Recommend

We have carefully selected several similar problems for you: 1002 1090 1003 1091 1004

Statistic | Submit | Discuss | Note

translation

A number per line, then every other line output a number, this number is added to the input number from 1 and.

Thinking

Circulation? Is certainly not ah, because the input of each line are 32-bit. Therefore, you should use a well-known formula -

i=1ni=n(n+1)2

Therefore, each number can be O (1) the request.

Code

#include <iostream>

int main(int argc, char ** argv)
{
    std::ios_base::sync_with_stdio(false);
    long long x;
    while (std::cin >> x)
        std::cout << x * (x + 1) / 2 << std::endl << std::endl;
//底下就是暂停用的,不用管。
#ifdef __EDWARD_EDIT
    std::cin.get();
    std::cin.get();
#endif
    return 0;
}
Published 40 original articles · won praise 0 · Views 5160

Guess you like

Origin blog.csdn.net/edward00324258/article/details/72542377