poj3250(优先队列)

Bad Hair Day

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 23081   Accepted: 7910

Description

Some of Farmer John's N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows' heads.

Each cow i has a specified height hi (1 ≤ hi ≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cow i can see the tops of the heads of cows in front of her (namely cows i+1, i+2, and so on), for as long as these cows are strictly shorter than cow i.

Consider this example:

        =
=       =
=   -   =         Cows facing right -->
=   =   =
= - = = =
= = = = = =
1 2 3 4 5 6 

Cow#1 can see the hairstyle of cows #2, 3, 4
Cow#2 can see no cow's hairstyle
Cow#3 can see the hairstyle of cow #4
Cow#4 can see no cow's hairstyle
Cow#5 can see the hairstyle of cow 6
Cow#6 can see no cows at all!

Let ci denote the number of cows whose hairstyle is visible from cow i; please compute the sum of c1 through cN.For this example, the desired is answer 3 + 0 + 1 + 0 + 1 + 0 = 5.

Input

Line 1: The number of cows, N.
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i.

Output

Line 1: A single integer that is the sum of c1 through cN.

Sample Input

6
10
3
7
4
12
2

Sample Output

5

Source

USACO 2006 November Silver

主要是思维的转化:转化成本牛被几个牛看到。

优先队列。(单调栈也可)

#include <cstdio>
#include <cstring>
#include<queue>
using namespace std;
typedef long long LL;


int main()
{
    int n;
    LL x;
    while(scanf("%d",&n)!=EOF){
        priority_queue<int,vector<int>,greater<int> >small;
        scanf("%lld",&x);
        small.push(x);
        LL ans=0;
        for(int i=1;i<n;i++){
            scanf("%lld",&x);
            while(x>=small.top()&&small.empty()==0){
                small.pop();
            }
            ans+=small.size();
            small.push(x);
        }
        printf("%lld\n",ans);
    }
}
发布了565 篇原创文章 · 获赞 110 · 访问量 11万+

猜你喜欢

转载自blog.csdn.net/xianpingping/article/details/86905322