4.7 其它高效技巧与算法:A1093 Count PAT's

A1093 Count PAT's

The string APPAPT contains two PAT's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT's contained in the string.

Input Specification:

Each input file contains one test case. For each case, there is only one line giving a string of no more than 10​5​​ characters containing only PA, or T.

Output Specification:

For each test case, print in one line the number of PAT's contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

Sample Input:

APPAPT

Sample Output:

2

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
using namespace std;
const int maxn=100010;
const int MOD=1000000007;
char str[maxn];
int leftNumP[maxn]={0};
int main(){
    gets(str);
    int len=strlen(str);
    for(int i=0;i<len;i++){
        if(i>0)
            leftNumP[i]=leftNumP[i-1];
        if(str[i]=='P')
            leftNumP[i]++;
    }
    int ans=0,rightNumT=0;
    for(int i=len-1;i>=0;i--){
        if(str[i]=='T')
            rightNumT++;
        else if(str[i]=='A')
            ans=(ans+leftNumP[i]*rightNumT)%MOD;
    }
    printf("%d\n",ans);
    return 0;
}
发布了157 篇原创文章 · 获赞 15 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/nanke_4869/article/details/104626795