poj 1028

题目

Web Navigation
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 33497   Accepted: 14937

Description

Standard web browsers contain features to move backward and forward among the pages recently visited. One way to implement these features is to use two stacks to keep track of the pages that can be reached by moving backward and forward. In this problem, you are asked to implement this. 
The following commands need to be supported: 
BACK: Push the current page on the top of the forward stack. Pop the page from the top of the backward stack, making it the new current page. If the backward stack is empty, the command is ignored. 
FORWARD: Push the current page on the top of the backward stack. Pop the page from the top of the forward stack, making it the new current page. If the forward stack is empty, the command is ignored. 
VISIT : Push the current page on the top of the backward stack, and make the URL specified the new current page. The forward stack is emptied. 
QUIT: Quit the browser. 
Assume that the browser initially loads the web page at the URL http://www.acm.org/

Input

Input is a sequence of commands. The command keywords BACK, FORWARD, VISIT, and QUIT are all in uppercase. URLs have no whitespace and have at most 70 characters. You may assume that no problem instance requires more than 100 elements in each stack at any time. The end of input is indicated by the QUIT command.

Output

For each command other than QUIT, print the URL of the current page after the command is executed if the command is not ignored. Otherwise, print "Ignored". The output for each command should be printed on its own line. No output is produced for the QUIT command.

Sample Input

VISIT http://acm.ashland.edu/
VISIT http://acm.baylor.edu/acmicpc/
BACK
BACK
BACK
FORWARD
VISIT http://www.ibm.com/
BACK
BACK
FORWARD
FORWARD
FORWARD
QUIT

Sample Output

http://acm.ashland.edu/
http://acm.baylor.edu/acmicpc/
http://acm.ashland.edu/
http://www.acm.org/
Ignored
http://acm.ashland.edu/
http://www.ibm.com/
http://acm.ashland.edu/
http://www.acm.org/
http://acm.ashland.edu/
http://www.ibm.com/
Ignored

题意分析

类似于浏览器左上角的前进和回退的模拟。

代码

Source Code

Problem: 1028   User: PaladinDu
Memory: 176K   Time: 32MS
Language: C++   Result: Accepted
  • Source Code
    #include<stdio.h>
    #include<string.h>
    int main(){
            char buf[105][80],action[10],top,temp;
            strcpy(buf[1],"http://www.acm.org/");
            scanf("%s",action);
    	top=temp=1;
            while(strcmp(action,"QUIT")!=0)
            {
                    if(strcmp(action,"VISIT")==0)
                    {
    			top=temp;
    			top++;
    			temp=top;
                            scanf("%s",buf[top]);
                            printf("%s\n",buf[top]);
                    }else if(strcmp(action,"BACK")==0)
                    {
                            if(temp-1>0)printf("%s\n",buf[--temp]);
    			else printf("Ignored\n");
                    }else if(strcmp(action,"FORWARD")==0)
                    {
                            if(temp+1<=top)printf("%s\n",buf[++temp]);
    			else printf("Ignored\n");
    		}
                    scanf("%s",action);
    	}
    	return 0;
    }

发布了54 篇原创文章 · 获赞 1 · 访问量 2万+

猜你喜欢

转载自blog.csdn.net/u011255131/article/details/53580588