Incredible Chess(尼姆博弈)

You are given an n x n chess board. Only pawn is used in the ‘Incredible Chess’ and they can move forward or backward. In each column there are two pawns, one white and one black. White pawns are placed in the lower part of the board and the black pawns are placed in the upper part of the board.

The game is played by two players. Initially a board configuration is given. One player uses white pieces while the other uses black. In each move, a player can move a pawn of his piece, which can go forward or backward any positive integer steps, but it cannot jump over any piece. White gives the first move.

The game ends when there is no move for a player and he will lose the game. Now you are given the initial configuration of the board. You have to write a program to determine who will be the winner.

Example of a Board
Input

Input starts with an integer T (≤ 200), denoting the number of test cases.

Each case starts with an integer n (3 ≤ n ≤ 100) denoting the dimension of the board. The next line will contain n integers, W0, W1, …, Wn-1 giving the position of the white pieces. The next line will also contain n integers, B0, B1, … Bn-1 giving the position of the black pieces. Wi means the row position of the white piece of ith column. And Bi means the row position of the black piece of ith column. You can assume that (0 ≤ Wi < Bi < n) for (0 ≤ i < n) and at least one move is remaining.
Output

For each case, print the case number and ‘white wins’ or ‘black wins’ depending on the result.
Sample Input

2

6

1 3 2 2 0 1

5 5 5 3 1 2

7

1 3 2 2 0 4 0

3 4 4 3 1 5 6

Sample Output

Case 1: black wins

Case 2: white wins
#include<stdio.h>

int main(void)
{
	int a[205],b[205];
	int i,t,n,t1=1;
	scanf("%d",&t);
	while(t--)
	{
		int temp=0;
		scanf("%d",&n);
		for(i=1;i<=n;i++)
			scanf("%d",&a[i]);
		for(i=1;i<=n;i++)
			scanf("%d",&b[i]);
		for(i=1;i<=n;i++)
			temp^=(b[i]-a[i]-1);
		printf("Case %d: ",t1++);
		if(temp==0)
			printf("black wins\n");
		else
			printf("white wins\n");
	}
	return 0;
 } 
发布了53 篇原创文章 · 获赞 1 · 访问量 1354

猜你喜欢

转载自blog.csdn.net/fgets__/article/details/99212319