PAT乙级真题 1038 统计同成绩学生 C++实现

题目

本题要求读入 N 名学生的成绩,将获得某一给定分数的学生人数输出。
输入格式:
输入在第 1 行给出不超过10^5的正整数 N,即学生总人数。随后一行给出 N 名学生的百分制整数成绩,中间以空格分隔。最后一行给出要查询的分数个数 K(不超过 N 的正整数),随后是 K 个分数,中间以空格分隔。
输出格式:
在一行中按查询顺序给出得分等于指定分数的学生人数,中间以空格分隔,但行末不得有多余空格。
输入样例:
10
60 75 90 55 75 99 82 90 75 50
3 75 90 88
输出样例:
3 2 0

思路

类似于桶排序的思想,用空间换时间。

建立数组,将每个分数作为下标,对应改分数的人数。这样就能根据分数(下标)直接索引到人数。

代码

#include <iostream>
#include <vector>
using namespace std;

int main(){
    //提高cin、cout效率
    ios::sync_with_stdio(false);
    cin.tie(0);

    vector<int> s(101);
    int n;
    int temp;

    cin >> n;
    for (int i=0; i<n; i++){
       cin >> temp; 
       s[temp]++;
    }

    cin >> n;
    for (int i=0; i<n; i++){
        cin >> temp;
        if (i!=0){
            cout << " ";
        }
        cout << s[temp];
    }

    cout << endl;
    return 0;
}
发布了105 篇原创文章 · 获赞 7 · 访问量 1764

猜你喜欢

转载自blog.csdn.net/zhang35/article/details/103710192