pat 1002

1002 A+B for Polynomials (25分)
 

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

N1​​ aN1​​​​ N2​​ aN2​​​​ ... NK​​ aNK​​​​

where K is the number of nonzero terms in the polynomial, Ni​​ and aNi​​​​ (,) are the exponents and coefficients, respectively. It is given that 1,0.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5
 

Sample Output:

3 2 1.5 1 2.9 0 3.2
有一个坑点,系数为0的时候不能加入答案,也不能判断mp[*it]大于0,否则有一个测试点会出错
 
 
#include<bits/stdc++.h>
using namespace std;
map<int, double> mp;
set<int> s;
int main(){
    int k1,k2,i=0;
    cin >> k1;
    while(k1--){
        double a;
        int N;
        cin >> N >> a;
        s.insert(N);
        mp[N] += a;
    }
    cin >> k2;
    while(k2--){
        double a;
        int N;
        cin >> N >> a;
        s.insert(N);
        mp[N] += a;
    }
    for(auto& p:s){
        if(mp[p]!=0)//等于0的直接跳过
            i++;
    }
    printf("%d", i);
    set<int>::iterator it = s.end();
    do{
        it--;
        if(mp[*it]!=0)printf(" %d %.1lf", *it, mp[*it]);
    } while (it != s.begin());
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/zlwjy/p/12099220.html