dp(最大分段和)

http://acm.hdu.edu.cn/showproblem.php?pid=1024

Max Sum Plus Plus

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 45548    Accepted Submission(s): 16529


Problem Description
Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ i y ≤ j x or i x ≤ j y ≤ j x is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^
 
Input
Each test case will begin with two integers m and n, followed by n integers S 1, S 2, S 3 ... S n.
Process to the end of file.
 
Output
Output the maximal summation described above in one line.
 
Sample Input
1 3 1 2 3 2 6 -1 4 -2 3 -2 3
 
Sample Output
6 8
Hint
Huge input, scanf and dynamic programming is recommended.
 
Author
JGShining(极光炫影)
 
//#include <bits/stdc++.h>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <iostream>
#include <string>
#include <stdio.h>
#include <queue>
#include <stack>
#include <map>
#include <set>
#include <string.h>
#include <vector>
#define ME(x , y) memset(x , y , sizeof(x))
#define SF(n) scanf("%d" , &n)
#define rep(i , n) for(int i = 0 ; i < n ; i ++)
#define INF  0x3f3f3f3f
#define mod 1000000007
#define PI acos(-1)
using namespace std;
typedef long long ll ;
int a[1000009];
int dp[1000009];
int Max[1000009];

int main()
{
    int n ,  m;
    while(~scanf("%d%d" , &n , &m))
    {
        for(int i = 1 ; i <= m ; i++)
        {
            scanf("%d" , &a[i]);
        }
        memset(dp , 0 , sizeof(dp));
        memset(Max , 0 , sizeof(Max));
        int mmax ;
        for(int i = 1 ; i <= n ; i++)
        {
            mmax = -INF ;
            for(int j = i ; j <= m ; j++)
            {
                dp[j] = max(dp[j - 1] , Max[j - 1]) + a[j];
                Max[j-1] = mmax ;
                mmax = max(mmax , dp[j]);
            }
        }
        cout << mmax << endl;

    }

    return 0;
}

猜你喜欢

转载自www.cnblogs.com/nonames/p/11709850.html
今日推荐