PAT甲级1002-数学模拟

1002. A+B for Polynomials (25)-PAT甲级真题

Details:This time, you are supposed to find A+B where A and B are two polynomials.

Input
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < … < N2 < N1 <=1000.

Output
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output
3 2 1.5 1 2.9 0 3.2

题目大意:计算多项式A+B的和(按指数降序给出),降序输出系数不为0的指数和系数

思路分析:设立一个二维数组,一个放系数一个放指数,让后接受a,b.将对应的指数加入到c中(相同的指数系数直接相加),然后输出系数不为零的指数和系数

Codes

#include<cstdio>
int main(){
      int k,m,d,count=0;
      double a[10][2],b[10][2],c[20][2]={0.0};
      scanf("%d",&k);
      for(int i=0;i<k;i++){
        scanf("%d %lf",&d,&a[i][1]);
              a[i][0]=d;
      }
      scanf("%d",&m);
      for(int i=0;i<m;i++){
          scanf("%d %lf",&d,&b[i][1]);
           b[i][0]=d;
      }
      int x=0,y=0;
      while(x<k&&y<m){
          if(a[x][0]>b[y][0]){
              c[count][0]=a[x][0];
              c[count][1]=a[x][1];
                x++;
                if(c[count][1]!=0)
                {
                    count++;
                    }

            }
            else if(a[x][0]==b[y][0]){
                c[count][0]=a[x][0];
                c[count][1]=a[x][1]+b[y][1];
                x++;
                y++;
                 if(c[count][1]!=0)
                {
                    count++;
                    }
            }
            else{
                c[count][0]=b[y][0];
                c[count][1]=b[y][1];
                y++;
                 if(c[count][1]!=0)
                {
                    count++;
                    }
            }

      }
      while(x<k){
              c[count][0]=a[x][0];
              c[count][1]=a[x][1];
                x++;
                 if(c[count][1]!=0)
                {
                    count++;
                    }
      }

      while(y<m){
                c[count][0]=b[y][0];
                c[count][1]=b[y][1];
                y++;
                 if(c[count][1]!=0)
                {
                    count++;
                    }

      }
      printf("%d",count);
    for(int i=0;i<20;i++){
        if(c[i][1]!=0){
            printf(" %d %.1f",(int)c[i][0],c[i][1]);
        }

       }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Winebrowen/article/details/80066493