PTA L1-062 幸运彩票 (15 分)

版权声明:转载请附上原文链接哟! https://blog.csdn.net/weixin_44170305/article/details/89811640

如花美眷,似水流年,回得了过去,回不了当初。

彩票的号码有 6 位数字,若一张彩票的前 3 位上的数之和等于后 3 位上的数之和,则称这张彩票是幸运的。本题就请你判断给定的彩票是不是幸运的。

输入格式:

输入在第一行中给出一个正整数 N(≤ 100)。随后 N 行,每行给出一张彩票的 6 位数字。

输出格式:

对每张彩票,如果它是幸运的,就在一行中输出 You are lucky!;否则输出 Wish you good luck.

输入样例:

2
233008
123456

输出样例:

You are lucky!
Wish you good luck.
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
int main()
{
    int n;
    int sz;
    cin>>n;
    while(n--)
    {
        cin>>sz;
        if(sz/100000+sz/10000%10+sz/1000%10==sz%10+sz%100/10+sz%1000/100)
            cout<<"You are lucky!"<<endl;
        else
            cout<<"Wish you good luck."<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_44170305/article/details/89811640