POJ - 1456 优先队列(小根堆)+贪心 并查集+贪心

A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σ x∈Sellpx. An optimal selling schedule is a schedule with a maximum profit. 
For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80. 


Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products. 

Input

A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.

Output

For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.

Sample Input

4  50 2  10 1   20 2   30 1

7  20 1   2 1   10 3  100 2   8 2
   5 20  50 10

Sample Output

80
185

Hint

The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.

第一种贪心是:

t天时,在不卖出过期食品的前提下,尽量卖出前t大的商品。

按天数贪心,先把商品按过期时间从小到大排序,扫一遍,如果当前商品的过期时间小于天数则把商品价值加入优先队列中,

如果等于,则于队首元素比较(在队列中最小的商品价值),大于则交换。

遍历完就是最优解。决策包容性…………。

#include<cstdio>
#include<algorithm>
#include<iostream>
#include<queue>
//#include<bits/stdc++.h>
using namespace std;
const int M = 1000000+100;
struct node
{
	int p,d;
}SU[M];
priority_queue<int,vector<int>,greater<int> >q;      
bool cmp(node a,node b)
{
	return a.d<b.d;
}
int main()
{
	int n;
	while(~scanf("%d",&n))
	{
		for(int i=1;i<=n;i++)
			scanf("%d%d",&SU[i].p,&SU[i].d);
//		printf("%d %d====\n",SU[n].p,SU[n].d);
		sort(SU+1,SU+1+n,cmp);
		int sum=0,num=0;
		for(int i=1;i<=n;i++)
		{
			if(SU[i].d>num)
			{
				q.push(SU[i].p);
				num++;
			}
			else if(SU[i].d==num)
			{
				if(SU[i].p>q.top())
				{
					q.pop();
					q.push(SU[i].p);
				}
			}
		}
		while(q.size())
		{
			sum+=q.top();
			q.pop();
		}
		printf("%d\n",sum);
	}
	return 0;
 } 

第二种贪心。

按照利润从大到小。。选择。

选择的商品尽力往物品过期前的天数放。

这个操作可以用并查集来执行(一步到位,不需要每次再进行往前扫描)。

#include<cstdio>
#include<algorithm>
#include<iostream>
#include<queue>
//#include<bits/stdc++.h>
using namespace std;
const int M = 1000000+100;
struct node
{
	int p,d;
}SU[M];
int  fa[M];
int get(int x)
{
	if(fa[x]==x)
	return x;
	return fa[x]=get(fa[x]);
}
void merge(int x,int y)
{
	fa[get(x)]=get(y);
}
bool cmp(node a,node b)
{
	return a.p>b.p;
}
int main()
{
	int n;
	while(~scanf("%d",&n))
	{
		for(int i=1;i<=10000;i++)
		fa[i]=i;
		for(int i=1;i<=n;i++)
			scanf("%d%d",&SU[i].p,&SU[i].d);
//		printf("%d %d====\n",SU[n].p,SU[n].d);
		sort(SU+1,SU+1+n,cmp);
		int sum=0,num=0;
		for(int i=1;i<=n;i++)
		{
			int d=SU[i].d,r=get(d);
			if(r>0)
			{
			//	printf("%d %d --   %d \n",i,SU[i].p,d);
				sum+=SU[i].p;
				merge(r,r-1);
			}
		}
		printf("%d\n",sum);
	}
	return 0;
 } 

猜你喜欢

转载自blog.csdn.net/bjfu170203101/article/details/88983476