度度熊的01世界 (深搜 判断联通体)

度度熊是一个喜欢计算机的孩子,在计算机的世界中,所有事物实际上都只由0和1组成。 

现在给你一个n*m的图像,你需要分辨他究竟是0,还是1,或者两者均不是。 

图像0的定义:存在1字符且1字符只能是由一个连通块组成,存在且仅存在一个由0字符组成的连通块完全被1所包围。 

图像1的定义:存在1字符且1字符只能是由一个连通块组成,不存在任何0字符组成的连通块被1所完全包围。 

连通的含义是,只要连续两个方块有公共边,就看做是连通。 

完全包围的意思是,该连通块不与边界相接触。 

Input

本题包含若干组测试数据。 
每组测试数据包含: 
第一行两个整数n,m表示图像的长与宽。 
接下来n行m列将会是只有01组成的字符画。 

满足1<=n,m<=100 

Output

如果这个图是1的话,输出1;如果是0的话,输出0,都不是输出-1。 

Sample Input

32 32
00000000000000000000000000000000
00000000000111111110000000000000
00000000001111111111100000000000
00000000001111111111110000000000
00000000011111111111111000000000
00000000011111100011111000000000
00000000111110000001111000000000
00000000111110000001111100000000
00000000111110000000111110000000
00000001111110000000111110000000
00000001111110000000011111000000
00000001111110000000001111000000
00000001111110000000001111100000
00000001111100000000001111000000
00000001111000000000001111000000
00000001111000000000001111000000
00000001111000000000000111000000
00000000111100000000000111000000
00000000111100000000000111000000
00000000111100000000000111000000
00000001111000000000011110000000
00000001111000000000011110000000
00000000111000000000011110000000
00000000111110000011111110000000
00000000111110001111111100000000
00000000111111111111111000000000
00000000011111111111111000000000
00000000111111111111100000000000
00000000011111111111000000000000
00000000001111111000000000000000
00000000001111100000000000000000
00000000000000000000000000000000
32 32
00000000000000000000000000000000
00000000000000001111110000000000
00000000000000001111111000000000
00000000000000011111111000000000
00000000000000111111111000000000
00000000000000011111111000000000
00000000000000011111111000000000
00000000000000111111110000000000
00000000000000111111100000000000
00000000000001111111100000000000
00000000000001111111110000000000
00000000000001111111110000000000
00000000000001111111100000000000
00000000000011111110000000000000
00000000011111111110000000000000
00000001111111111111000000000000
00000011111111111111000000000000
00000011111111111111000000000000
00000011111111111110000000000000
00000000001111111111000000000000
00000000000000111111000000000000
00000000000001111111000000000000
00000000000111111110000000000000
00000000000011111111000000000000
00000000000011111111000000000000
00000000000011111111100000000000
00000000000011111111100000000000
00000000000000111111110000000000
00000000000000001111111111000000
00000000000000001111111111000000
00000000000000000111111111000000
00000000000000000000000000000000
3 3
101
101
011

Sample Output

0
1
-1

思路:就是深搜找联通块,先找0 的联通块,然后再找1 的连通块,如果还有0 的联通块就继续。。。。

#include<iostream>
#include<cmath>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAX = 1e2 + 10;
typedef long long LL;
char s[MAX][MAX];
int n,m,vis[MAX][MAX];
void dfs(int x,int y,char c){
    if(x < 0 || y < 0 || x > n ||y > m )
        return ;
    if(vis[x][y])
        return ;
    if(s[x][y]!=c)
        return ;    
	vis[x][y] = 1;
    dfs(x+1,y,c);
    dfs(x-1,y,c);
    dfs(x,y+1,c);
    dfs(x,y-1,c);
}
int main()
{
    while(~scanf("%d %d",&n,&m)){        
	    memset(vis,0,sizeof(vis));
	    getchar();
        for(int i=1;i<=n;i++){
            for(int j=1;j<=m;j++){
            	scanf("%c",&s[i][j]);
			}
			getchar();
	    }
        n++;
		m++;
        for(int i = 0; i <= n; i++) s[i][0] = s[i][m] = '0';
        for(int i = 0; i <= m; i++) s[0][i] = s[n][i] = '0';//加上一圈墙 
        int num1 = 0,num0 = 0;
        for(int i = 0; i <= n; i++)
            for(int j = 0; j <= m; j++){
                if(!vis[i][j]){//肯定是从0开始,先把一圈0 遍历一遍,然后遍历1,如果还有0,再遍历
                    if(s[i][j] == '1') //遍历不同的联通块 
					    num1++;
                    else 
					    num0++;
                    dfs(i,j,s[i][j]);
                }
            }
        if(num1 == 1 && num0 == 1) 
            cout<<"1"<<endl; 
        else if(num1 == 1 && num0 == 2)
            cout<<"0"<<endl; 
        else 
            cout<<"-1"<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/red_red_red/article/details/88408608