The Dole Queue

In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros
Party has decided on the following strategy. Every day all dole applicants will be placed in a large
circle, facing inwards. Someone is arbitrarily chosen as number 1, and the rest are numbered counterclockwise up to N (who will be standing on 1’s left). Starting from 1 and moving counter-clockwise,
one labour official counts off k applicants, while another official starts from N and moves clockwise,
counting m applicants. The two who are chosen are then sent off for retraining; if both officials pick
the same person she (he) is sent off to become a politician. Each official then starts counting again
at the next available person and the process continues until no-one is left. Note that the two victims
(sorry, trainees) leave the ring simultaneously, so it is possible for one official to count a person already
selected by the other official.
Input
Write a program that will successively read in (in that order) the three numbers (N, k and m; k, m > 0,
0 < N < 20) and determine the order in which the applicants are sent off for retraining. Each set of
three numbers will be on a separate line and the end of data will be signalled by three zeroes (0 0 0).
Output
For each triplet, output a single line of numbers specifying the order in which people are chosen. Each
number should be in a field of 3 characters. For pairs of numbers list the person chosen by the counterclockwise official first. Separate successive pairs (or singletons) by commas (but there should not be a
trailing comma).
Note: The symbol ⊔ in the Sample Output below represents a space.
Sample Input
10 4 3
0 0 0
Sample Output
␣␣4␣␣8,␣␣9␣␣5,␣␣3␣␣1,␣␣2␣␣6,␣10,␣␣7
代码
#include<stdio.h>
#include<stdlib.h>
#include<ctype.h>
#include<string.h>
int a[27];
int main()
{
int n,m,k,t,p,q,i;
while(scanf("%d%d%d",&n,&k,&m)&&(n!=0||m!=0||k!=0))
{
t=n;
p=n-1;
q=0;
while(t>0)
{
for(i=0;i<k;i++)
{
do
{
if(pn-1)
p=0;
else
p++;
}while(a[p]!=0);
}
for(i=0;i<m;i++)
{
do
{
if(q
0)
q=n-1;
else
q–;
}while(a[q]!=0);
}
//output
printf("%3d",p+1);
t–;
if(p!=q)
{
printf("%3d",q+1);
t–;
}
a[p]=1;
a[q]=1;
if(t!=0)
printf(",");
}
puts("");
memset(a,0,sizeof(a));
}
return 0;
}
学习

猜你喜欢

转载自blog.csdn.net/weixin_43797508/article/details/86314638