Babelfish POJ - 2503 (map || 二分查找)

版权声明: https://blog.csdn.net/nucleare/article/details/82856423

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

Input

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

Output

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

Sample Input

dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay

Sample Output

cat
eh
loops

Hint

Huge input and output,scanf and printf are recommended.

用map做的话代码很简单但耗时用了1900多ms

代码

#include<iostream>
#include<map>
#include<cstdio>
#include<string>
using namespace std;

int main(void)
{
	map<string,string>mp;
	char s[100],s1[100],s2[100];
	while(gets(s)&&s[0]!='\0')
	{
		sscanf(s,"%s %s",s1,s2);
		mp[s2]=s1;
	}
	while(gets(s))
	{
		if(mp.find(s)!=mp.end())
		cout<<mp[s]<<endl;
		else
		cout<<"eh"<<endl;
	}
	return 0;
}

用二分查找的话耗时大约700ms

代码

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
const int N = 1e6 + 7;
typedef struct disi {
	char eng[12], fore[12]; // 英语及对应的外语 
}disi;

disi dis[N];

bool cmp(disi a,disi b) {  //比较函数 
	return strcmp(a.fore, b.fore) < 0;
}

 int main() {
 	
 	int k = 0;
 	while (~scanf ("%s %s", dis[k].eng, dis[k].fore)) {
 		getchar();
 		++k;
 		if (cin.peek()=='\n') break; // cin.peek() 探查输入流的下一个字符 
 	}
 	sort(dis, dis+k, cmp); // 把外语从小到大排序 
 	char word[15];
 	while (~scanf ("%s", word)) {
 		
 		int left = 0, right = k-1, m;
 		while (left <= right) { // 二分查找 
 			int mid = (left+right)/2;
 			m = strcmp(dis[mid].fore, word);
 			if (m < 0) {
 				left = mid + 1;
 			} else if (m > 0) {
 				right = mid - 1;
 			} else {
 				printf ("%s\n", dis[mid].eng);
 				break;
 			}
 		}
 		if (m) { //如果没有找到 
 			puts("eh");
 		}
 		
 	}
 	
 	
 	return 0;
 }

猜你喜欢

转载自blog.csdn.net/nucleare/article/details/82856423
今日推荐