HDU 5363 Key Set(快速幂)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/suguoliang/article/details/81257979

Key Set

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 2750    Accepted Submission(s): 1373


 

Problem Description

soda has a set S with n integers {1,2,…,n} . A set is called key set if the sum of integers in the set is an even number. He wants to know how many nonempty subsets of S are key set.

 

Input

There are multiple test cases. The first line of input contains an integer T (1≤T≤105) , indicating the number of test cases. For each test case:

The first line contains an integer n (1≤n≤109) , the number of integers in the set.

 

Output

For each test case, output the number of key sets modulo 1000000007.

 

Sample Input

 

4 1 2 3 4

 

Sample Output

 

0 1 3 7

给你一个具有n个元素的集合S{1,2,…,n},问集合S的非空子集中元素和为偶数的非空子集有多少个。放入出题人的解题报告解题思路:因为集合S中的元素是从1开始的连续的自然数,所以所有元素中奇数个数与偶数个数相同,或比偶数多一个。另外我们要知道偶数+偶数=偶数,奇数+奇数=偶数,假设现在有a个偶数,b个奇数,则根据二项式展开公式以及二项式展开式中奇数项系数之和等于偶数项系数之和的定理可以得到上式最后的结果还需减去即空集的情况,因为题目要求非空子集所以最终结果为由于n很大,所以计算n次方的时候需要用到快速幂

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int mod=1000000007;
int quick_pow(long long a,long long  b)
{
    long long  ans=1;
    a=a%mod;
    while(b)
    {
        if(b&1)
        {
            ans=(ans%mod)*(a%mod);
        }
        b>>=1;
        a=(a*a)%mod;
    }
    ans=ans%mod;
    printf("%I64d\n",ans-1);
}
int main()
{
    int n,i,j,k,t;
    scanf("%d\n",&n);
    while(n--)
    {
        long long m;
        scanf("%lld",&m);
        quick_pow(2,m-1);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/suguoliang/article/details/81257979
今日推荐