1093 Count PAT's

The string APPAPT contains two PAT’s as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT’s contained in the string.

Input Specification:
Each input file contains one test case. For each case, there is only one line giving a string of no more than 10
​5
​​ characters containing only P, A, or T.

Output Specification:
For each test case, print in one line the number of PAT’s contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

Sample Input:
APPAPT
Sample Output:
2
分析:给定只含有P、A、T三种字符的字符串,求组成的PAT的个数。要找个数,只需找到A之前P的个数np,和A之后T的个数nt,然后np*pt就是包含这个A个PAT个数。
先遍历字符串,记录T的总个数nt;然后再遍历字符串,若字符为P,np自增一;若字符为T,则nt自减一;若字符为A,包含此A的PAT的个数为np*nt;
参考代码:

#include<iostream>
#include<string>
#include<vector>
#define N 1000000007
using namespace std;

int main()
{
    string s;
    cin >> s;
    int result = 0, nump = 0, numt = 0;
    for (int i = 0; i < s.size(); i++) {
        if (s[i] == 'T')
            numt++;
    }
    for (int i = 0; i < s.size(); i++) {
        if (s[i] == 'P')nump++;
        else if (s[i] == 'T')numt--;
        else if (s[i] == 'A') result = (result + (nump*numt) % N) % N;
    }
    cout << result;

    return 0;
}

猜你喜欢

转载自blog.csdn.net/ssf_cxdm/article/details/82502509