PAT 甲级 1093 Count PAT's(统计)

1093 Count PAT's(25 分)

The string APPAPT contains two PAT's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT's contained in the string.

Input Specification:

Each input file contains one test case. For each case, there is only one line giving a string of no more than 10​5​​ characters containing only P, A, or T.

Output Specification:

For each test case, print in one line the number of PAT's contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

Sample Input:

APPAPT

Sample Output:

2

Analysis:

a statistical problem .

C++:

#include<stdio.h>
#include<iostream>
#include<string>
#include<vector>
#include<map>
#include<queue>
#include<set>
#include<math.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
	string s;
	int p=0,a=0,t;
	long long sum=0;
	cin>>s;
	for(int i=0;i<s.length();i++){
		if(s[i]=='P')
			p++;//count the number of 'p'
		else if(s[i]=='A')
			a+=p;//count the number of "PA"
		else
			sum=((sum%1000000007)+(a%1000000007))%1000000007;//count the number of "PAT"
	}
	cout<<sum<<endl;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/zpjlkjxy/article/details/82320103