C - Tree

题目:

You are to determine the value of the leaf node in a given binary tree that is the terminal node of a path of least value from the root of the binary tree to any leaf. The value of a path is the sum of values of nodes along that path.

Input

The input file will contain a description of the binary tree given as the inorder and postorder traversal sequences of that tree. Your program will read two line (until end of file) from the input file. The first line will contain the sequence of values associated with an inorder traversal of the tree and the second line will contain the sequence of values associated with a postorder traversal of the tree. All values will be different, greater than zero and less than 10000. You may assume that no binary tree will have more than 10000 nodes or less than 1 node.

Output

For each tree description you should output the value of the leaf node of a path of least value. In the case of multiple paths of least value you should pick the one with the least value on the terminal node.

Sample Input

3 2 1 4 5 7 6

3 1 2 5 6 7 4

7 8 11 3 5 16 12 18

8 3 11 7 16 18 12 5

255

255

Sample Output

1

3

255

题意:

根据中序遍历和后序遍历构造出二叉树,输出的是最小路径的叶子节点;

思路:

1 找出后续数组的最后一个元素。

2 以后序数组的最后一个元素为根据,将中序数组分成左子树和右子树。

3 以中序数组的左子树右子树为根据,将后序数组分为左子树和右子树。

4 将中序左子树,后序左子树作为一个新的,中序数组和后序数组,进行递归。同时将新根数的根赋值给先前根的左儿子。

5 同理并同时处理右子树。

代码如下:

#include<iostream>
#include<string.h>
#include<sstream>
#include<algorithm>
using namespace std;

const int maxv=10010;
int in[maxv],post[maxv],l[maxv],r[maxv];
int n;

bool read_list(int *a)
{
    string line;
    if(!getline(cin,line))
        return false;
    stringstream ss(line);//分割字符串;
    n=0;
    int x;
    while(ss>>x)
        a[n++]=x;
    return n>0;
}

int build(int l1,int r1,int l2,int r2)
{
    if(l1>r1)
        return 0;
    int root=post[r2];
    int p=l1;
    while(in[p]!=root)
        p++;
    int cnt=p-l1;
    l[root]=build(l1,p-1,l2,l2+cnt-1);
    r[root]=build(p+1,r1,l2+cnt,r2-1);
    return root;
}

int best,bests;

void dfs(int u,int sum)
{
    sum+=u;
    if(!l[u]&&!r[u])
    {
        if(sum<bests||(sum==bests&&u<best))
        {
            best=u;
            bests=sum;
        }
    }
    if(l[u])
        dfs(l[u],sum);
    if(r[u])
        dfs(r[u],sum);
}

int main()
{
    while(read_list(in))
    {
        read_list(post);
        build(0,n-1,0,n-1);
        bests=1000000000;
        dfs(post[n-1],0);
        cout<<best<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/titi2018815/article/details/82082987
今日推荐