NYOJ 72

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_34075012/article/details/78528728

Financial Management

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 1
描述
Larry graduated this year and finally has a job. He's making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what's been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.
输入
The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.
输出
The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output.
样例输入
100.00
489.12
12454.12
1234.10
823.05
109.20
5.27
1542.25
839.18
83.99
1295.01
1.75
样例输出
1581.42
求12个月的平均值。

AC代码:

 
#include <iostream>
#include <cstdio>

using namespace std;

int main()
{
    double a[12];
    double sum = 0.0;
    for(int i = 0; i < 12;i++){
        scanf("%lf",&a[i]);
        sum += a[i];
    }
    printf("%.2lf\n",sum/12);
    return 0;
}
        


猜你喜欢

转载自blog.csdn.net/qq_34075012/article/details/78528728
72