【ACM】一种排序

一种排序

时间限制: 3000 ms  |  内存限制:65535 KB
难度: 3
 
描述
现在有很多长方形,每一个长方形都有一个编号,这个编号可以重复;还知道这个长方形的宽和长,编号、长、宽都是整数;现在要求按照一下方式排序(默认排序规则都是从小到大);

1.按照编号从小到大排序

2.对于编号相等的长方形,按照长方形的长排序;

3.如果编号和长都相同,按照长方形的宽排序;

4.如果编号、长、宽都相同,就只保留一个长方形用于排序,删除多余的长方形;最后排好序按照指定格式显示所有的长方形;
 
输入
第一行有一个整数 0<n<10000,表示接下来有n组测试数据;
每一组第一行有一个整数 0<m<1000,表示有m个长方形;
接下来的m行,每一行有三个数 ,第一个数表示长方形的编号,

第二个和第三个数值大的表示长,数值小的表示宽,相等
说明这是一个正方形(数据约定长宽与编号都小于10000);
输出
顺序输出每组数据的所有符合条件的长方形的 编号 长 宽
样例输入
1
8
1 1 1
1 1 1
1 1 2
1 2 1
1 2 2
2 1 1
2 1 2
2 2 1
样例输出
1 1 1
1 2 1
1 2 2
2 1 1
2 2 1
 
#include <iostream>
#include <algorithm>
#include <cstdio>

using namespace std;


struct myRectangle{

    int x;
    int y;
    int z;

};


bool cmp(myRectangle r1, myRectangle r2){

    if (r1.x != r2.x)
    {
        return r1.x < r2.x;
    }
    else
    {
        if (r1.y != r2.y)
        {
            return r1.y < r2.y;
        }
        else
        {
            return r1.z < r2.z;
        }
    }

}

int main(){

    int n;
    cin>>n;
    int m;
    while (n--)
    {
        cin>>m;
        myRectangle *a = new myRectangle[m];
        for (int i = 0 ; i < m; i++)
        {
            myRectangle temp;
            int y,z;
            cin>>temp.x>>y>>z;
            if (z>y)
            {
                temp.y = z;
                temp.z = y;
            }
            else
            {
                temp.y = y;
                temp.z = z;
            }
            a[i] = temp;
        }
        sort(a,a+m,cmp);
        cout<<a[0].x<<" "<<a[0].y<<" "<<a[0].z<<endl;
        for (int k = 1; k < m ; k++)
        {
            if (a[k].x != a[k-1].x || a[k].y!=a[k-1].y || a[k].z!=a[k-1].z)
            {
                cout<<a[k].x<<" "<<a[k].y<<" "<<a[k].z<<endl;
            }
        }
    }

    return 0;
}        

猜你喜欢

转载自www.cnblogs.com/lyc94620/p/9543353.html