[KMP] BZOJ 1511/POI2006 OKR-period of words

题目描述

A string is a finite sequence of lower-case (non-capital) letters of the English alphabet. Particularly, it may be an empty sequence, i.e. a sequence of 0 letters. By A=BC we denotes that A is a string obtained by concatenation (joining by writing one immediately after another, i.e. without any space, etc.) of the strings B and C (in this order). A string P is a prefix of the string !, if there is a string B, that A=PB. In other words, prefixes of A are the initial fragments of A. In addition, if P!=A and P is not an empty string, we say, that P is a proper prefix of A.

A string Q is a period of Q, if Q is a proper prefix of A and A is a prefix (not necessarily a proper one) of the string QQ. For example, the strings abab and ababab are both periods of the string abababa. The maximum period of a string A is the longest of its periods or the empty string, if A doesn't have any period. For example, the maximum period of ababab is abab. The maximum period of abc is the empty string.

Task Write a programme that:

reads from the standard input the string's length and the string itself,calculates the sum of lengths of maximum periods of all its prefixes,writes the result to the standard output.

一个串是有限个小写字符的序列,特别的,一个空序列也可以是一个串. 一个串P是串A的前缀, 当且仅当存在串B, 使得 A = PB. 如果 P!=A 并且 P 不是一个空串,那么我们说 P 是A的一个proper前缀. 定义Q 是A的周期, 当且仅当Q是A的一个proper 前缀并且A是QQ的前缀(不一定要是proper前缀). 比如串 abab 和 ababab 都是串abababa的周期. 串A的最大周期就是它最长的一个周期或者是一个空串(当A没有周期的时候), 比如说, ababab的最大周期是abab. 串abc的最大周期是空串. 给出一个串,求出它所有前缀的最大周期长度之和.。

输入输出格式

输入格式:

In the first line of the standard input there is one integer k \((1\le k\le 1\ 000\ 000)\) - the length of the string. In the following line a sequence of exactly k lower-case letters of the English alphabet is written - the string.

输出格式:

In the first and only line of the standard output your programme should write an integer - the sum of lengths of maximum periods of all prefixes of the string given in the input.

输入输出样例

输入样例#1:

8
babababa

输出样例#1:
24

题解

一个字符串A的proper前缀的定义满足四个条件

  1. 为A的前缀
  2. 不能为空
  3. P!=A
  4. A为PP的前缀,但不一定要是poper前缀
    题目要我们求每个子串最长poper前缀长度之和,那么我们可以画一张图

    我们假设P为A的最长poper前缀,在P复制一遍接在后面后,如需要满足条件,则A为PP的前缀,可以得出涂黑的一段和下面对应位置上的子串是一样的,而这一段子串是由P复制而来的,也就是说这一段子串是A的一个前缀,而涂黑的子串为A的一个后缀,如需要P的长度最大,则涂黑部分需最小,也就是求A的最短公共前后缀
    所以我们转换一下,next[i]表示i-1的最短公共前后缀
    那么怎么求它呢?
    我们可以在原来的kmp算法中,依然先求出i的最长公共前后缀,然后不断向前跳,因为要满足条件P不为空,所以
while(next[next[i]]) next[i]=next[next[i]]

Code

#include<cstdio>
#include<string>
#include<iostream>
#include<cstring>
#include<cmath>
#define Min(a,b) (a)<(b)?(a):(b)
#define Max(a,b) (a)>(b)?(a):(b)
#define in(i) (i=read())
using namespace std;
int read() {
  int ans=0,f=1; char i=getchar();
  while(i<'0' || i>'9') {if(i=='-') f=-1; i=getchar();}
  while(i>='0' && i<='9') {ans=(ans<<1)+(ans<<3)+i-'0'; i=getchar();}
  return ans*f;
}
int ans,n;
int nex[1000010];
char s[1000010];
void get() {
  int p=0;
  for(int i=1;i<n;i++) {
    while(p && s[p]!=s[i]) p=nex[p];
    if(s[p]==s[i]) nex[i+1]=(++p);
    else nex[i+1]=0;
  }
}
void match() {
  for(int i=1;i<=n;i++) {
    while(nex[nex[i]]) nex[i]=nex[nex[i]];
    if(nex[i]) ans+=i-nex[i];
  }
}
int main()
{
  in(n); scanf("%s",s);
  get(); match();
  printf("%d\n",ans);
  return 0;
}

博主蒟蒻,随意转载.但必须附上原文链接

http://www.cnblogs.com/real-l/

猜你喜欢

转载自www.cnblogs.com/real-l/p/9478306.html