POJ 1753 Flip Game (状态压缩 bfs+位运算)

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:
  1. Choose any one of the 16 pieces.
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example:

bwbw
wwww
bbwb
bwwb
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:

bwbw
bwww
wwwb
wwwb
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

题目意思:

有一个4*4的方格,每个方格中放一粒棋子,这个棋子一面是白色,一面是黑色。游戏规则为每次任选16颗中的一颗,把选中的这颗以及它四周的棋子一并反过来,当所有的棋子都是同一个颜色朝上时,游戏就完成了。现在给定一个初始状态,要求输出能够完成游戏所需翻转的最小次数,如果初始状态已经达到要求输出0。如果不可能完成游戏,输出Impossible。

分析:

主要思想:

1、如果用一个4*4的数组存储每一种状态,不但存储空间很大,而且在穷举状态时也不方便记录。因为每一颗棋子都只有两种状态,所以可以用二进制0和1表示每一个棋子的状态,则棋盘的状态就可以用一个16位的整数唯一标识。而翻转的操作也可以通过通过位操作来完成。显然当棋盘状态id为0(全白)或65535(全黑)时,游戏结束。

2、对于棋盘的每一个状态,都有十六种操作,首先要判断这十六种操作之后是否有完成的情况,如果没有,则再对这十六种操作的结果分别再进行上述操作,显然这里就要用到队列来存储了。而且在翻转的过程中有可能会回到之前的某种状态,而这种重复的状态是不应该再次入队的,所以维护 Visit[i]数组来判断 id==i 的状态之前是否已经出现过,如果不是才将其入队。如果游戏无法完成,状态必定会形成循环,由于重复状态不会再次入队,所以最后的队列一定会是空队列。

3、由于0^1=1,1^1=0,所以翻转的操作可以通过异或操作来完成,而翻转的位置可以通过移位来确定。

 注意:有16个棋子,所以用2进制状态压缩,用^=进行翻棋子的操作, 当然要判断一下在不在棋盘内,接着就是枚举每个状态16个棋子翻的状态,进行判断,如果超了16步就是不可能了,因为相当于一个棋子翻过去又翻回来,没有意义了。

第二个位运算的题,还得继续加油啊

code:

#include<stdio.h>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <math.h>
#include <cstdlib>
#include <queue>
using namespace std;
const int max_v=(1<<16)-1;
int vis[max_v+10];
int step;
queue<int> q;
int change(unsigned int x,int i,int j)//记住x是无符号数 执行翻转当前棋子和当前棋子周围四个棋子的操作
{
    int k;
    k=(1<<(i*4+j));//当前位置
    x^=k;//翻转
    if(i-1>=0)
    {
        k=(1<<(4*(i-1)+j));//当前位置的上面一个位置
        x^=k;//翻转棋子
    }
    if(i+1<4)
    {
        k=(1<<(4*(i+1)+j));//
        x^=k;//翻转
    }
    if(j+1<4)
    {
        k=(1<<(4*i+j+1));//
        x^=k;//翻转
    }
    if(j-1>=0)
    {
        k=(1<<(4*i+j-1));//
        x^=k;//翻转
    }
    return x;
}
int bfs(int state)//state代表当前棋盘的状态
{
    step=0;
    while(!q.empty()) q.pop();
    q.push(state);

    while(!q.empty())
    {
        int t=q.size();
        for(int i=0;i<t;i++)
        {
            int k=q.front();
            q.pop();

            if(k==0||k==max_v||step>16)//全黑 或 全白 或 步数大于16(因为相当于一个棋子翻过去又翻回来,没有意义了。)
                return step;
            for(int x=0;x<4;x++)//16个点,对应16种操作
                for(int y=0;y<4;y++)
                {
                    int w;
                    w=change(k,x,y);//翻转棋盘
                    if(!vis[w])//判断此状态的棋盘有没有算过
                        q.push(w);
                    vis[w]=1;//标记
                }
        }
        step++;
    }
}
int main()
{
    int state=0;
    char s[10];
    int k=0;
    for(int i=0;i<4;i++)
    {
       scanf("%s",s);
       for(int j=0;j<4;j++)
       {
           if(s[j]=='b')
            state+=(1<<k);
           k++;
       }
    }
    int ans=bfs(state);
    if(ans>16)
        cout<<"Impossible"<<endl;
    else
        cout<<ans<<endl;
        return 0;
}

猜你喜欢

转载自www.cnblogs.com/yinbiao/p/9392210.html