J - Simpsons’ Hidden Talents

J - Simpsons’ Hidden Talents

Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had. 
Marge: Yeah, what is it? 
Homer: Take me for example. I want to find out if I have a talent in politics, OK? 
Marge: OK. 
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix 
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton 
Marge: Why on earth choose the longest prefix that is a suffix??? 
Homer: Well, our talents are deeply hidden within ourselves, Marge. 
Marge: So how close are you? 
Homer: 0! 
Marge: I’m not surprised. 
Homer: But you know, you must have some real math talent hidden deep in you. 
Marge: How come? 
Homer: Riemann and Marjorie gives 3!!! 
Marge: Who the heck is Riemann? 
Homer: Never mind. 
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.

Input

Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.

Output

Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0. 
The lengths of s1 and s2 will be at most 50000.

Sample Input

clinton
homer
riemann
marjorie

Sample Output

0
rie 3

题意:

            多组输入,给出两个字符串——a,b,求a的前缀和b的后缀最长公共串。

 

思路: 

            将a,b连接起来,利用KMP求最长相同前后缀。

注意:

next[la+llb] 不能大于 a或b 的长度。大于的话,应输出小的字符串。

扫描二维码关注公众号,回复: 2294804 查看本文章

代码:

#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
#define MOD 10007
const int MM=50010;
#define mem(a,b) memset(a,b,sizeof(a))

int ne[MM<<1];
char mo[MM<<1];
int lm;
void Get_next()
{
    int i=0,j=-1;
    ne[0]=-1;
    while(i<lm)
    {
        while(j!=-1&&mo[i]!=mo[j])
            j=ne[j];
        ne[++i]=++j;
    }
}
int main()
{
    char s[MM];
    while(~scanf("%s%s",mo,s))
    {
        lm=strlen(mo);
        int  ls=strlen(s);
        int lmin=min(lm,ls);
        strcat(mo,s);
        mem(ne,0);
        lm=strlen(mo);
        Get_next();
        if(ne[lm]==0)      //没有相同的
            printf("0\n");
        else if(ne[lm]>lmin)     //相同长度大于 a或b 的长度
           {
               if(lmin<ls)          //a<b
                printf("%s %d\n",s+ls-lmin,lmin);
               else                //a>b
                printf("%s %d\n",s,lmin);
           }
        else
            printf("%s %d\n",mo+lm-ne[lm],ne[lm]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/team39/article/details/81095423