Coder Pat之路 1093 Count PAT's

1093 Count PAT's (25)(25 分)

The string APPAPT contains two PAT's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT's contained in the string.

Input Specification:

Each input file contains one test case. For each case, there is only one line giving a string of no more than 10^5^ characters containing only P, A, or T.

Output Specification:

For each test case, print in one line the number of PAT's contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

Sample Input:

APPAPT

Sample Output:

 
    

2

User: 吴锦诚

Date: 2018/6/12

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <string>
#include <string.h>
using namespace std;
char ch[100010];
int pNum[100010];
int main()
{
	int len=0 ,i;
	
	string s;
	getline(cin, s);
	strcpy(ch, s.c_str());
	len = strlen(ch);
	/*
	while ((temp = getchar()) && temp != '\n') {
		ch[len] = temp;
		len++;
	}
	*/
	memset(pNum, 0, sizeof(pNum));
	for (i = 0; i < len; i++) {
		if (i > 0)
			pNum[i] = pNum[i - 1];
		if (ch[i] == 'P')
			pNum[i]++;
	}
	long long  ans = 0, rightNum = 0;
	for (i =(len -1); i >=0; i--) {
		if (ch[i] == 'T')
			rightNum++;
		else if(ch[i] == 'A'){
			ans = (ans + rightNum * pNum[i])% 1000000007;
		}
	}
	cout << ans << endl;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/morizunzhu/article/details/80673512