第一个A

1046 Shortest Distance (20)(20 分)

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 10^5^]), followed by N integer distances D~1~ D~2~ ... D~N~, where D~i~ is the distance between the i-th and the (i+1)-st exits, and D~N~ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=10^4^), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10^7^.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10

#include <cstdio>
#include <algorithm>
using namespace std;
const int N=100005;
int dis[N],a[N]; 
int main()
{
	int n,m,right,left;
	scanf("%d",&n);	
	int sum=0;
	for(int i=1;i<=n;i++)
	{
		scanf("%d",&a[i]);
		sum+=a[i];
	    dis[i]=sum;
	}
	scanf("%d",&m);
	while(m--)
	{
		int b,c;
		scanf("%d%d",&right,&left);
		if (right<left) swap(right,left);
		int temp=dis[right-1]-dis[left-1];
		printf("%d\n",min(temp,sum-temp));
	} 	
	return 0;
}

有点可笑   一道题难了三天 写下来发现也并没有想象中那么难

dis 保存第一个结点顺时针方向到达i+1号结点的距离    这样可保存第N到第一个节点的距离  之所以用dis数组保存  在赋值给数组时就进行保存dis 以防遍历数组同时查询 会超时

注意可以用algorithm

猜你喜欢

转载自blog.csdn.net/coding18/article/details/80795540