PTA|《C语言程序设计实验与习题指导(第3版)》实验10-1 圆形体体积计算器 (20分)

题目

本题要求实现一个常用圆形体体积的计算器。计算公式如下:

  • 球体体积 V = 4 3 π r 3 V=\frac 4 3\pi{r^3} ,其中 r r 是球体半径。
  • 圆柱体体积 V = π r 2 h V=\pi{r^2}h ,其中r是底圆半径,h是高。
  • 圆锥体体积 V = 1 3 π r 2 h V=\frac 1 3\pi{r^2}h ,其中r是底圆半径,h是高。

输入格式:
在每次计算之前,要求输出如下界面:

1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:

然后从标准输入读进一个整数指令。

输出格式:
如果读入的指令是1或2或3,则执行相应的体积计算;如果是其他整数,则程序结束运行。

  • 当输入为1时,在计算球体体积之前,打印Please enter the radius:,然后读入球体半径,完成计算;
  • 当输入为2时,在计算圆柱体体积之前,打印Please enter the radius and the height:,然后读入底圆半径和高,完成计算;
  • 当输入为3时,在计算圆锥体体积之前,打印Please enter the radius and the height:,然后读入底圆半径和高,完成计算。

计算结果在一行内输出,保留小数点后两位。

输入样例:

1
2
3
2.4 3
0

输出样例:

1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:
Please enter the radius:
33.51
1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:
Please enter the radius and the height:
18.10
1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:

AC代码

  • 结构化程序,将功能模块化,看起来比较清晰
  • 开始 π \pi 设置为3.1415926,以为精度够了,一直在琢磨测试点3到底哪里有问题。确定代码没问题之后,提高了 π \pi 的精度。结果是, π \pi 的精度至少是3.1415926535才能全部通过,以下是各精度能通过的测试点
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
#include<stdio.h>
#include<math.h>
#define PI 3.1415926535

void menu(void);    //输出选项界面
void ball(void);    //计算球体体积
void cylinder(void);    //计算圆柱体体积
void cone(void);    //计算圆锥体体积

int main(){
    int command;
    while(1){
        menu();
        scanf("%d",&command);
        switch(command){
            case 1:ball();break;
            case 2:cylinder();break;
            case 3:cone();break;
            default:return 0;
        }
    }
}
void menu(){
    printf("1-Ball\n");
    printf("2-Cylinder\n");
    printf("3-Cone\n");
    printf("other-Exit\n");
    printf("Please enter your command:\n");
}
void ball(void){
    double r,V;
    printf("Please enter the radius:\n");
    scanf("%lf",&r);
    V=(4.0/3)*PI*pow(r,3);
    printf("%.2lf\n",V);
}
void cylinder(void){
    double r,h,V;
    printf("Please enter the radius and the height:\n");
    scanf("%lf %lf",&r,&h);
    V=h*PI*pow(r,2);
    printf("%.2lf\n",V);
}
void cone(void){
    double r,h,V;
    printf("Please enter the radius and the height:\n");
    scanf("%lf %lf",&r,&h);
    V=(1.0/3)*h*PI*pow(r,2);
    printf("%.2lf\n",V);
}
发布了188 篇原创文章 · 获赞 31 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/weixin_44421292/article/details/104710608