ACM 1456

/*A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σx∈Sellpx. An optimal selling schedule is a schedule with a maximum profit.
For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80.

Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products.
Input
A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.
Output
For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.
Sample Input
4  50 2  10 1   20 2   30 1
7  20 1   2 1   10 3  100 2   8 2
   5 20  50 10
Sample Output
80
185
*/
#include <cstdio>   //具有C库功能的新C++头文件具有如<cstdio>这样的名字。它们提供的内容和相应的旧C头文件<stdio.h>相同,只是内容在std中。
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#include <stack>
#include <vector>
using namespace std;
typedef struct
{
    int p, d;
}node;
node a[10000+10];
bool flag[10000+10];
bool cmp(node a, node b)
{
    return a.p > b.p;
}
int main()
{
    //freopen("data.in" , "r" , stdin);
    int n ;
    while(scanf("%d", &n) != EOF)
    {
        memset(flag , true , sizeof(flag));
        for(int i = 0 ; i < n  ; i ++)
            scanf("%d %d", &a[i].p, &a[i].d);
        sort(a , a + n , cmp);
        int ans = 0;
        for(  i = 0 ; i < n ; i ++)
        {
            for(int j = a[i].d ; j > 0 ; j --)
            {
                if(flag[j])
                {
                    flag[j] = false;
                    ans += a[i].p;
                    break;
                }
            }
        }
        printf("%d\n" , ans );
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_38855717/article/details/80374819