POJ 1665

Biker's Trip Odometer

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 5827   Accepted: 3648

Description

Most bicycle speedometers work by using a Hall Effect sensor fastened to the front fork of the bicycle. A magnet is attached to one of the spokes on the front wheel so that it will line up with the Hall Effect switch once per revolution of the wheel. The speedometer monitors the sensor to count wheel revolutions. If the diameter of the wheel is known, the distance traveled can be easily be calculated if you know how many revolutions the wheel has made. In addition, if the time it takes to complete the revolutions is known, the average speed can also be calculated. 
For this problem, you will write a program to determine the total distance traveled (in miles) and the average speed (in Miles Per Hour) given the wheel diameter, the number of revolutions and the total time of the trip. You can assume that the front wheel never leaves the ground, and there is no slipping or skidding.

Input

Input consists of multiple datasets, one per line, of the form: 
diameter revolutions time 
The diameter is expressed in inches as a floating point value. The revolutions is an integer value. The time is expressed in seconds as a floating point value. Input ends when the value of revolutions is 0 (zero).

Output

For each data set, print: 
Trip #N: distance MPH 
Of course N should be replaced by the data set number, distance by the total distance in miles (accurate to 2 decimal places) and MPH by the speed in miles per hour (accurate to 2 decimal places). Your program should not generate any output for the ending case when revolutions is 0.

Sample Input

26 1000 5
27.25 873234 3000
26 0 1000

Sample Output

Trip #1: 1.29 928.20
Trip #2: 1179.86 1415.84

Hint

Constants 
For p use the value: 3.1415927. 
There are 5280 feet in a mile. 
There are 12 inches in a foot. 
There are 60 minutes in an hour. 
There are 60 seconds in a minute. 
There are 201.168 meters in a furlong.

Source

Greater New York 2003

大致题意:

告诉你车轮直径(英寸),车轮滚了多少圈,花了多长时间(小时),还告诉你英寸英尺英里转换,π的近似值,时间的转换。问你走了多长的路和平均车速。

解题思路:

这题主要就是注意单位的换算。题目中直径给的是inche英尺,给的时间是second秒,但是最终要求的是路程是多少mile英里,速度求的是每hour 小时多少mile英里,只要把单位换算清楚就可以了,还有就是直径和时间是浮点型,圈数是整型。

代码:

#include<stdio.h>
int main()
{    
    double d,s;   
    int n,i=0;
    while(scanf("%lf%d%lf",&d,&n,&s),n!=0)
    {
         i++; 
         d=3.1415927*d/12/5280*n;
         s=d/s*60*60;   
         printf("Trip #%d: %.2f %.2f\n",i,d,s);
    }
}
发布了158 篇原创文章 · 获赞 34 · 访问量 8万+

猜你喜欢

转载自blog.csdn.net/qq_40421671/article/details/95207458
POJ