POJ 2346

Lucky tickets

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 3484   Accepted: 2294

Description

The public transport administration of Ekaterinburg is anxious about the fact that passengers don't like to pay for passage doing their best to avoid the fee. All the measures that had been taken (hard currency premiums for all of the chiefs, increase in conductors' salaries, reduction of number of buses) were in vain. An advisor especially invited from the Ural State University says that personally he doesn't buy tickets because he rarely comes across the lucky ones (a ticket is lucky if the sum of the first three digits in its number equals to the sum of the last three ones). So, the way out is found — of course, tickets must be numbered in sequence, but the number of digits on a ticket may be changed. Say, if there were only two digits, there would have been ten lucky tickets (with numbers 00, 11, ..., 99). Maybe under the circumstances the ratio of the lucky tickets to the common ones is greater? And what if we take four digits? A huge work has brought the long-awaited result: in this case there will be 670 lucky tickets. But what to do if there are six or more digits? 
So you are to save public transport of our city. Write a program that determines a number of lucky tickets for the given number of digits. By the way, there can't be more than 10 digits on one ticket.

Input

Input contains a positive even integer N not greater than 10. It's an amount of digits in a ticket number.

Output

Output should contain a number of tickets such that the sum of the first N/2 digits is equal to the sum of the second half of digits.

Sample Input

4

Sample Output

670

Source

Ural State University Internal Contest October'2000 Students Session

大致题意:

定义一个位数为偶数的数为幸运数当且仅当这个数前一半的部分数字之和等于后一半的数字之和,给出一个n,求出有多少个位数小于n的数是幸运数。

解题思路:

就是求n/2位数有多少种不同的和

1、dp[ i ][ j ]表示为第 i 位和为 j 的数有多少

2、ans为dp[ n/2 ][ 0 ~ n/2*9 ]平方和

代码:

#include<cstdio>
#include<iostream>
using namespace std;
int dp[6][50];
void init(){
	dp[0][0]=1;
	for(int i=1;i<=5;i++){
		for(int j=0;j<=i*9;j++){
			for(int k=0;k<=9;k++){
				if(j>=k)dp[i][j]+=dp[i-1][j-k];
			}
		}
	}
}
int main(){
	init();
	int n;
	scanf("%d",&n);
	int sum=0;
	for(int i=0;i<=n/2*9;i++){
		sum+=dp[n/2][i]*dp[n/2][i];
	}
	printf("%d\n",sum);
	return 0;
}
发布了158 篇原创文章 · 获赞 34 · 访问量 8万+

猜你喜欢

转载自blog.csdn.net/qq_40421671/article/details/95485993
POJ