POJ 2556

Edge

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 1360   Accepted: 923

Description

For products that are wrapped in small packings it is necessary that the sheet of paper containing the directions for use is folded until its size becomes small enough. We assume that a sheet of paper is rectangular and only folded along lines parallel to its initially shorter edge. The act of folding along such a line, however, can be performed in two directions: either the surface on the top of the sheet is brought together, or the surface on its bottom. In both cases the two parts of the rectangle that are separated by the folding line are laid together neatly and we ignore any differences in thickness of the resulting folded sheet. 

After several such folding steps have been performed we may unfold the sheet again and take a look at its longer edge holding the sheet so that it appears as a one-dimensional curve, actually a concatenation of line segments. If we move along this curve in a fixed direction we can classify every place where the sheet was folded as either type A meaning a clockwise turn or type V meaning a counter-clockwise turn. Given such a sequence of classifications, produce a drawing of the longer edge of the sheet assuming 90 degree turns at equidistant places.

Input

The input contains several test cases, each on a separate line. Each line contains a nonempty string of characters A and V describing the longer edge of the sheet. You may assume that the length of the string is less than 200. The input file terminates immediately after the last test case.

Output

For each test case generate a PostScript drawing of the edge with commands placed on separate lines. Start every drawing at the coordinates (300,420) with the command "300 420 moveto". The first turn occurs at (310,420) using the command "310 420 lineto". Continue with clockwise or counter-clockwise turns according to the input string, using a sequence of "x y lineto" commands with the appropriate coordinates. The turning points are separated at a distance of 10 units. Do not forget the end point of the edge and finish each test case by the commands stroke and showpage. 

You may display such drawings with the gv PostScript interpreter, optionally after a conversion using the ps2ps utility.

Sample Input

V
AVV

Sample Output

300 420 moveto
310 420 lineto
310 430 lineto
stroke
showpage
300 420 moveto
310 420 lineto
310 410 lineto
320 410 lineto
320 420 lineto
stroke
showpage

Source

Ulm Local 2003

大致题意:

给你一条线段AB A(300,420) B(310,420)
操作A顺时针旋转90°
操作V逆时针旋转90°
每次以B为中心旋转
每次选择后  交换AB坐标
输出B的坐标

解题思路:

模拟

代码:

#include<iostream>
using namespace std;
char s[256];
 
int main()
{
	while(scanf("%s",&s)==1){
		int px=300,py=420;
		int x=310,y=420;
		puts("300 420 moveto\n310 420 lineto");
		for(int i=0;s[i]!='\0';++i){
			int dx=x-px,ddx;
			int dy=y-py,ddy;
			px=x;
			py=y;
			if(s[i]=='V'){
				ddx=-dy;
				ddy=dx;	
			}else if(s[i]=='A'){
				ddx=dy;
				ddy=-dx;
			}
			x=x+ddx;
			y=y+ddy;
			printf("%d %d lineto\n",x,y);	
		}
		puts("stroke\nshowpage");
	}
	return 0;	
} 
发布了158 篇原创文章 · 获赞 34 · 访问量 8万+

猜你喜欢

转载自blog.csdn.net/qq_40421671/article/details/96729467
POJ