pta--1028 List Sorting(25 分)(sort cmp重写)

1028 List Sorting(25 分)

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:

Each input file contains one test case. For each case, the first line contains two integers N (≤10​5​​) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.

Sample Input 1:

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1:

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2:

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2:

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3:

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample Output 3:

000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

【分析】重写三个sort函数就可以了

#include<bits/stdc++.h>
using namespace std;
struct inf{
	char id[10];
	char name[10];
	int grade;
}a[100005];
bool cmp(inf x,inf y)
{
	return strcmp(x.id,y.id)<0;
}
bool cmp1(inf x,inf y)
{
	return strcmp(x.name,y.name)<=0;
}
bool cmp2(inf x,inf y)
{
	return x.grade<=y.grade;
}
int main()
{
	int N,C;
	scanf("%d%d",&N,&C);
	for(int i=0;i<N;i++)
		scanf("%s%s%d",a[i].id,a[i].name,&a[i].grade);
	if(C==1)sort(a,a+N,cmp);
	else if(C==2)sort(a,a+N,cmp1);
	else if(C==3) sort(a,a+N,cmp2);
	for(int i=0;i<N;i++)
		printf("%s %s %d\n",a[i].id,a[i].name,a[i].grade);
	return 0;
 } 

猜你喜欢

转载自blog.csdn.net/qq_38735931/article/details/82181447